Mozmill test for Panorama tabgroup naming

RESOLVED FIXED

Status

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: ashughes, Assigned: aaronmt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-functional][mozmill-panorama])

Attachments

(2 attachments, 5 obsolete attachments)

(Reporter)

Updated

8 years ago
Blocks: 629050
Whiteboard: [mozmill-panorama]
(Assignee)

Updated

8 years ago
Depends on: 629436
(Reporter)

Updated

8 years ago
Duplicate of this bug: 631446
Created attachment 512878 [details]
Incomplete test script

Unsure how to check 1)A text entry field should appear.
Otherwise, I'd thought it'd look more or less like the attached file.
(Reporter)

Comment 3

8 years ago
(In reply to comment #2)
> Created attachment 512878 [details]
> Incomplete test script
> 
> Unsure how to check 1)A text entry field should appear.
> Otherwise, I'd thought it'd look more or less like the attached file.

Adam, can you change the attachment type to plain-text? It's not viewable in the browser as Javascript, thanks.
(Reporter)

Updated

8 years ago
Attachment #512878 - Attachment mime type: application/x-javascript → text/plain
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> > Created attachment 512878 [details]
> > Incomplete test script
> > 
> > Unsure how to check 1)A text entry field should appear.
> > Otherwise, I'd thought it'd look more or less like the attached file.
> 
> Adam, can you change the attachment type to plain-text? It's not viewable in
> the browser as Javascript, thanks.

Nevermind, I did it myself :)
(Reporter)

Comment 5

8 years ago
(In reply to comment #2)
> Created attachment 512878 [details]
> Incomplete test script
> 
> Unsure how to check 1)A text entry field should appear.
> Otherwise, I'd thought it'd look more or less like the attached file.

If you can get an instance of the groupTitleBox element and type a name in it, this should be sufficient.
(Assignee)

Comment 6

8 years ago
Hi Adam,

Did you still want to work on this test? Just checking because it's unassigned.
(Assignee)

Comment 7

8 years ago
Taking over this bug.
Assignee: nobody → aaron.train
(Assignee)

Comment 8

8 years ago
Created attachment 516794 [details] [diff] [review]
Patch v1 - automation script for testcase 12649

Simple automation script for testcase 12649 at
https://litmus.mozilla.org/show_test.cgi?id=12649
Attachment #512878 - Attachment is obsolete: true
Attachment #516794 - Flags: review?(hskupin)
(Assignee)

Comment 9

8 years ago
Comment on attachment 516794 [details] [diff] [review]
Patch v1 - automation script for testcase 12649

Switching initial reviewer
Attachment #516794 - Flags: review?(hskupin) → review?(anthony.s.hughes)
(Reporter)

Comment 10

8 years ago
Comment on attachment 516794 [details] [diff] [review]
Patch v1 - automation script for testcase 12649

>diff --git a/firefox/testTabView/testTabGroupNaming.js b/firefox/testTabView/testTabGroupNaming.js
>+// Include required modules
>+var tabView = require("../../shared-modules/tabview");
>+const TABGROUP_TITLE = "Mozilla";

nit, please separate "requires" and consts by a newline.

>+
>+function setupModule(module) {
>+  controller = mozmill.getBrowserController();
>+  tabView = new tabView.tabView(controller);
>+}

Please rename "tabView" to "activeTabView" to remove ambiguity with the shared module.

>+  // Check that Tab View has opened 
>+  controller.assert(function () {
>+    return tabView.isOpen;
>+  }, "Tab Groups has opened");
>+

Please refer to the Panorama view as "Tab Groups View" across all code and comments.
Attachment #516794 - Flags: review?(anthony.s.hughes) → review-
(Assignee)

Comment 11

8 years ago
Created attachment 518066 [details] [diff] [review]
Patch v2 - automation script for testcase 12649
Attachment #516794 - Attachment is obsolete: true
Attachment #518066 - Flags: review?(anthony.s.hughes)
(Assignee)

Updated

8 years ago
Attachment #518066 - Flags: review?(anthony.s.hughes)
(Assignee)

Updated

8 years ago
Attachment #518066 - Attachment is obsolete: true
(Assignee)

Comment 12

8 years ago
Created attachment 518068 [details] [diff] [review]
Patch v2 - automation script for testcase 12649
Attachment #518068 - Flags: review?(anthony.s.hughes)
(Reporter)

Comment 13

8 years ago
Comment on attachment 518068 [details] [diff] [review]
Patch v2 - automation script for testcase 12649

>+  // Check that Tab Groups View has opened 
>+  controller.assert(function () {
>+    return activeTabView.isOpen;
>+  }, "Tab Groups View has opened");

I'm not sure if this is redundant since .open() calls waitForOpen(). What do you think? Henrik?

>+  // Check that Tab Groups View has closed
>+  controller.assert(function () {
>+    return !activeTabView.isOpen;
>+  }, "Tab Groups View has closed");
>+}

Could you add a check to enter Tab Groups view and check the title once more (ie. make sure the title remains after switching in and out of Panorama)?
Attachment #518068 - Flags: review?(anthony.s.hughes) → review-
(In reply to comment #13)
> >+  // Check that Tab Groups View has opened 
> >+  controller.assert(function () {
> >+    return activeTabView.isOpen;
> >+  }, "Tab Groups View has opened");
> 
> I'm not sure if this is redundant since .open() calls waitForOpen(). What do
> you think? Henrik?

Exactly. It's not necessary.
(Assignee)

Comment 15

8 years ago
Created attachment 518368 [details] [diff] [review]
Patch v3 - automation script for testcase 12649
Attachment #518068 - Attachment is obsolete: true
Attachment #518368 - Flags: review?(anthony.s.hughes)
(Reporter)

Comment 16

8 years ago
Comment on attachment 518368 [details] [diff] [review]
Patch v3 - automation script for testcase 12649

This looks good to me.  Thanks Aaron.  Over to Henrik for follow-up.
Attachment #518368 - Flags: review?(hskupin)
Attachment #518368 - Flags: review?(anthony.s.hughes)
Attachment #518368 - Flags: review+
Comment on attachment 518368 [details] [diff] [review]
Patch v3 - automation script for testcase 12649

Please update the locations once the refactoring has been finished.
Attachment #518368 - Flags: review?(hskupin)
(Reporter)

Comment 18

8 years ago
Aaron, please submit a new patch for review by Henrik with the new file structure.
(Assignee)

Comment 19

8 years ago
Created attachment 518706 [details] [diff] [review]
Patch v4 - automation script for testcase 12649

Updated for restructuring changes yesterday. Over to Henrik for review.
Attachment #518368 - Attachment is obsolete: true
Attachment #518706 - Flags: review?(hskupin)
Comment on attachment 518706 [details] [diff] [review]
Patch v4 - automation script for testcase 12649

>+function testTabGroupNaming() {
>+  // Open Tab Groups View (default via keyboard shortcut)
[..]
>+  // Close Tab Groups View (default via keyboard shortcut)
>+  activeTabView.close();
>+
>+  // Open Tab Groups View (default via keyboard shortcut)
>+  activeTabView.open();

Nit: There is no need to call out the default in each test.
Attachment #518706 - Flags: review?(hskupin) → review+
(Assignee)

Comment 21

8 years ago
Created attachment 518844 [details] [diff] [review]
Patch v4.1 [nit addressed][checked-in]

Nit addressed and landed on default and 2.0
http://hg.mozilla.org/qa/mozmill-tests/rev/09a6c4063f88 (default)
http://hg.mozilla.org/qa/mozmill-tests/rev/1ccaf9638b3b (2.0)
Attachment #518844 - Flags: review+
(Assignee)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Updated

7 years ago
Whiteboard: [mozmill-panorama] → [mozmill-functional][mozmill-panorama]
You need to log in before you can comment on or make changes to this bug.