homeruns.com - blank page results from shopping

VERIFIED FIXED

Status

Tech Evangelism Graveyard
English US
P2
major
VERIFIED FIXED
18 years ago
3 years ago

People

(Reporter: buster, Assigned: Arun Ranganathan)

Tracking

Details

(Whiteboard: needs a better test case, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
Go to www.homeruns.com and click return customer.
Sign In: seamonkey
Password: seamonkey
Click Go
Click Start Shopping
Blank Screen
(Reporter)

Comment 1

18 years ago
mine for now
Status: NEW → ASSIGNED
OS: Windows NT → All
Priority: P3 → P2
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 2

18 years ago
Created attachment 20740 [details]
test case loads empty page.  remove the <form> and all it's content, and the page would load as expected if it could find the src of the frames
(Reporter)

Updated

18 years ago
Assignee: buster → harishd
Status: ASSIGNED → NEW
Whiteboard: needs a better test case
(Reporter)

Comment 3

18 years ago
just a guess...I think it's illegal to have the following construct

<html>
<head>...</head>
<form>...</form>   <!-- note, this <form> implies a <body> -->
<frameset>...</frameset>
</html>


I'll bet you a buck that we're not recognizing this document as a frameset
because of the <form>.  If the <form> wasn't there, we'd probably display just
fine.  But the <form> causes an implicit <body>, and you can't have a <body> and
a <frameset> in the same document.  We're doing the "right" thing here, AFAICT.
 But we're clearly not backwards compatible.

Rick, Harish, back me up on this, will you?

is this a quirks bug, or maybe just evangalism?
(Reporter)

Comment 4

18 years ago
*** Bug 62912 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
Buster, take a look at bug 62912 for that one, it's an evangwanted most def.
Friendly, HJ. (And shit, I didn't see this one around before seeing 62912)
(Reporter)

Comment 6

18 years ago
from bug 62912, tranferring Comments From H-J 2000-12-15 00:01 -------

I like to take this one, thank you.

1 - I'm missing a document type description like this one for example:
<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/REC-html40/frameset.dtd">  2 - there seems to be at least
3 JavaScript parts above the <html><head> section
on that page! That's illegal HTML format.

3 - Try to use: <script language="JavaScript" type="text/javascript"> instead
of: <script language="JavaScript">  4 - the <title></title> elements are
missing, every HTML page needs one. Even
    if you don't use them. See W3C HTML guidelines also!

5 - Seems to be a frameset, with an form in it!! Yeah right!

H-J's Tips for the web'master':
1 - always validate your pages at: http://validator.w3c.org/check 2 - consider
using Dave Ragget's 'Tidy'. You may find that, for free, at:
http://www.w3.org/People/Raggett/tidy/ 3 - and taking a look at:
http://www.htmlhelp.com/ might be really interesting
for you!

So, for now, evangwanted!
Friendly, HJ, see you next time around on planet Mozilla.

Comment 7

18 years ago
Created attachment 20764 [details]
Reduced test case [ INPUT causes a BODY to be opened ]

Comment 8

18 years ago
Content model for the above test case:
------------------------------------------

docshell=0119C6E0
html@02F03D08 refcount=8<
  head@02F03C18 refcount=2<
    Text@02EF6FB0 refcount=2<\n >
    base@02EF7CD8 href=http://601.homeruns.com/frames/mainframe.asp?addrID=1&ses
sionid=BD2BAC44D2AD11D48820009027E29700R0224JZVKN refcount=2<>
    title@02EC8978 refcount=2<
      Text@02EC7920 refcount=2<HomeRuns>
    >
  >
  Text@02EE55D0 refcount=3<\n>
  body@02EEAB18 refcount=3<
    form@02F0958C refcount=3<
      Text@02F0AE60 refcount=3<\n>
      input@02F0AD5C type=hidden name=MainLoading value=0 refcount=6<>
      Text@02F0A500 refcount=3<\n>
    >
    Text@02F0A420 refcount=3<\n\n               \n                         \n \n
\n>
  >
>
Status: NEW → ASSIGNED

Comment 9

18 years ago
AFAIK, we are doing the correct thing ( keep in mind the above URL is totally 
wacky! ) by opening up a BODY for the INPUT. Too bad that we are not 
backwards compatible in this case...but IMO we're heading towards the right 
direction. The above URL could be made to work by removing the FORM elements - 
as suggested by buster.  EVANGALISM please!

Comment 10

18 years ago
Please assign it to me when you need some evangelism fun, or I'll forget.  
Thanks!

Comment 11

18 years ago
Reassigning bug to Blake for evangelism.
Assignee: harishd → blakeross
Status: ASSIGNED → NEW

Comment 12

18 years ago
.
Assignee: blakeross → evangelism

Comment 13

17 years ago
Reassigning evangelism bugs to bclary@netscape.com.
Assignee: evangelism → bclary
WOW, this bug got lost.  ->Tech Evangelism
Component: Layout → English: US
Product: Browser → Tech Evangelism
QA Contact: petersen → zach
Version: other → unspecified
Summary: blank page results from shopping on homeruns.com → homeruns.com - blank page results from shopping

Comment 15

17 years ago
ecomm
Assignee: bclary → aruner
Component: US General → US Ecommerce
QA Contact: zach → bclary
URL gone.
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 17

16 years ago
Verified
2002042803/WinxP
Status: RESOLVED → VERIFIED
tech evang june 2003 reorg
Component: US Ecommerce → English US
Target Milestone: Jan → ---
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.