Warn about newer versions of 1Password

RESOLVED FIXED in Camino2.1

Status

RESOLVED FIXED
8 years ago
7 years ago

People

(Reporter: alqahira, Assigned: alqahira)

Tracking

unspecified
Camino2.1
All
Mac OS X
Bug Flags:
camino2.0.8 -
camino2.0.9 +
camino2.1 +
camino2.1b1 -

Details

(Whiteboard: [camino-2.0.9])

Some time ago I unfortunately took it upon myself to check to see if newer (.osax-based-hack) 1Passwords were still warned about on launch of a new version; they don't :(

The various 1Password-related crashes have spiked periodically in 2.0.x versions, and it currently is the source of most of the 2.1a1 crashes (the signatures in bug 413534, plus all of the current libobjc.A.dylib@0x5edb crashes--unresymbolized 10.6.6 objc_msgSend, whose next frame is AppKit 	-[NSToolbar _newItemFromItemIdentifier:propertyListRepresentation:requireImmediateLoad:willBeInsertedIntoToolbar:] ).

We should investigate making sure we warn about these newer versions (and maybe complain about them touching our delegate, if it looks like that's what they're still doing).
Flags: camino2.0.7?

Comment 1

8 years ago
I just installed 1Password and launched a recentish nightly build, and I got the warning and buttons to either enable or disable it for Camino.
Huh.  I'm sure I didn't, and I know I tested a release (we only warn on releases, IIRC).

(In reply to comment #1)
> the warning and buttons to either enable or disable it for Camino.

The buttons are clearly theirs, which is nice (but apparently not sufficient).

Comment 3

8 years ago
Maybe it was temporarily broken? I'm reluctant to add a warning if they have one, since a double warning will just be confusing and annoying for people.
I just double-checked in a test account, and on 10.5.8 we're warning on 1P 2.11.0 and 2.12.1 for Camino 2.0.6 and 2.1a1 (but not nightlies), and we not warning at all for 1P 3.5.4.

(In reply to comment #3)
> one, since a double warning will just be confusing and annoying for people.

More confusing and annoying than crashing when customizing the toolbar?

Also, at some point, the 1P devs will "test" against a new Camino version again, bump their "OK" version number, and will stop warning; however, there's no guarantee that they'll have fixed how the crash us.

I just went through the crashes and tried to correlate the crashes to the version of 1P installed (current version is 3.5.4, but it just came out ~wk ago; versions older than 2.9.4 are no longer available for download, and a few 2.x versions are missing):

18% 3.5.3
16% 3.5.0
16% 3.5.1
16% Unknown version (likely < 2.9.4)
11% 3.5.2
 7% 3.2.5
 4% 3.3.1
 2% 3.4.2
 2% 3.2.1
 2% 3.1.2
 2% Unknown version (likely < 2.9.4)
 2% Unknown version (likely < 2.9.4)
 2% Unknown version (likely < 2.9.4)

That's 61% of the crashes with a very recent version (3.5.x), and 88% with a version of 1P that we no longer warn about (that's assuming all the unknown versions are older than 2.9.4 and not betas or unreleased versions of 3.x).

I'd be more inclined to let it go if people weren't crashing with very current versions, but that's not what's happening.
(In reply to comment #4)
> and 88% with a version of 1P that we no longer warn about
Math failure; that's 78%

Comment 6

8 years ago
(In reply to comment #4)
> More confusing and annoying than crashing when customizing the toolbar?

But I don't think it's an either/or. I think will be additionally annoying, without necessarily helping people not crash.

> Also, at some point, the 1P devs will "test" against a new Camino version
> again, bump their "OK" version number, and will stop warning; however, there's
> no guarantee that they'll have fixed how the crash us.

Sure, but anyone auto-updating Camino is likely seeing a warning still, since a 1P update of the max tested version only matters if they update 1P first every time.

So unless we believe that most people are never seeing warnings (I have my doubts), or that people seeing two warnings will understand the source of their crashes but people who see only one won't (which I definitely don't think is true), re-adding our warning won't help.

The warning was never going to prevent people from having crashes, it was to give them a chance at understanding how to fix them. If people ignore warnings, I don't think we can help them. We should just send crash links to 1Password support, and let them fix their bug.

Comment 7

8 years ago
(Also, we should relnote their bug)

Comment 8

8 years ago
(In reply to comment #6)
> We should just send crash links to 1Password support, and let them fix their bug.

Email sent. I added it to the email thread where I told them about this problem back in late 2009 though, so I am not brimming with confidence.

I think release noting is the best thing for us to do at this point. Something like "1Password is known to crash Camino in some cases, particularly when customizing the toolbar. If you experience crashes, try removing 1Password's Camino integration."

Comment 9

8 years ago
(One thought that just occurred to me: if we want to eliminate the noise of crashes caused by 1Password, we should be able to set it up so that having 1Password loaded would turn off Breakpad.)
(In reply to comment #8)
> (In reply to comment #6)
> > We should just send crash links to 1Password support, and let them fix their bug.
> 
> Email sent. I added it to the email thread where I told them about this problem
> back in late 2009 though, so I am not brimming with confidence.

Heh.  Thanks!

> I think release noting is the best thing for us to do at this point. Something
> like "1Password is known to crash Camino in some cases, particularly when
> customizing the toolbar. If you experience crashes, try removing 1Password's
> Camino integration."

"…and contacting 1Password support" or somesuch.

(In reply to comment #9)
> (One thought that just occurred to me: if we want to eliminate the noise of
> crashes caused by 1Password, we should be able to set it up so that having
> 1Password loaded would turn off Breakpad.)

That's an interesting idea.  Would users then get the Mac OS X crash log (so that 1. there'd be some record of the crash and 2. any user coming to us with "I got the Mac OS X crash reporter instead of Camino's" we'd be able to tell 1Password immediately it's 1P)?

I'm not sure if I'd want to take that step right now, though.  It would be OK for the crashes in comment 0 which we know are their fault, but I'm not sure about what impact it might have on numbers for other crashes where the user having 1P installed is irrelevant (similar to all crashes I have where ChimericalConsole is installed; my crashes printing and dragging and in XPCOM GC aren't CC's fault, so they really shouldn't "disappear").

Comment 11

8 years ago
(In reply to comment #10)
> Would users then get the Mac OS X crash log

Yep.

> I'm not sure about what impact it might have on numbers for other crashes
> where the user having 1P installed is irrelevant

Obviously we'd lose some reports in terms of raw numbers, but it shouldn't impact rankings and percentages of other crashes; for crashes that are unrelated to 1Password, the population removed should be effectively random, so shouldn't skew anything.

I'm not trying to argue for doing it necessarily; it's not like there's much benefit to doing it. It would just save us the annoyance ;)

Comment 12

8 years ago
Let's just relnote this for now and reconsider later.
Flags: camino2.1b1?
Flags: camino2.1b1-
Flags: camino2.0.7?
Flags: camino2.0.7-
I was using the flags to make sure it got in the relnotes (because I always look at the flags towards endgame, whereas it's unlikely I'd look for a "relnote" keyword we almost never use) ;) but yes, that sounds like a plan.
Flags: camino2.1b1?
Flags: camino2.1b1-
Flags: camino2.0.7?
Flags: camino2.0.7-

Comment 14

8 years ago
Changing owner, given the new plan.
Assignee: stuart.morgan+bugzilla → alqahira

Comment 15

7 years ago
Just to capture here: Camino support has been officially dropped from 1Password. Users will have to choose whether they want to live with the bugs in the last version that supported it, or lose Camino integration.

Given that we can probably pass on the "and contacting 1Password support" part.
This got missed in the last releases; we should pick it up for 2.1 if we want to do it (I'm not even sure the last version that supported Camino supported 2.1 nightlies/milestones).
Flags: camino2.1b1?
Flags: camino2.1b1-
Flags: camino2.1+
Flags: camino2.0.8?
Flags: camino2.0.8-
Target Milestone: --- → Camino2.1
Draft known issue is in the 2.0.9 draft relnotes.
Flags: camino2.0.9? → camino2.0.9+
Whiteboard: [camino-2.0.9]
(In reply to Smokey Ardisson (offline for a while; no bugmail - do not email) from comment #17)
> Draft known issue is in the 2.0.9 draft relnotes.

Said relnotes landed, and there's a note on the 2.1 running fixes page to take it there, so FIXED.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.