--enable-nspr-autoconf busted by LDAP C SDK buildsystem

RESOLVED FIXED in mozilla1.2alpha

Status

SeaMonkey
Build Config
P3
normal
RESOLVED FIXED
17 years ago
13 years ago

People

(Reporter: David Krause, Assigned: dmose)

Tracking

Trunk
mozilla1.2alpha
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
I've been seeing this for several days now with the latest mozilla cvs source.
Whenever I do a gmake -f client.mk distclean it fails with the following.  Does
the ldap code not play nice with object directories?

gmake[2]: Leaving directory `/usr/local/src/mozilla/mozilla/obj-opt/mailnews'
gmake[2]: Entering directory
`/usr/local/src/mozilla/mozilla/obj-opt/directory/c-sdk/ldap'
build/autoconf.mk:55: ../../../nsprpub/config/autoconf.mk: No such file or directory
/usr/local/src/mozilla/mozilla/directory/c-sdk/ldap/../../../nsprpub/config/config.mk:121:
../../../config/module.df: No such file or directory
/usr/local/src/mozilla/mozilla/directory/c-sdk/ldap/../../../nsprpub/config/config.mk:123:
../../../config/arch.mk: No such file or directory
/usr/local/src/mozilla/mozilla/directory/c-sdk/ldap/../../../nsprpub/config/config.mk:147:
../../../config/.mk: No such file or directory
gmake[2]: *** No rule to make target `../../../config/.mk'.  Stop.
gmake[2]: Leaving directory
`/usr/local/src/mozilla/mozilla/obj-opt/directory/c-sdk/ldap'
gmake[1]: *** [distclean] Error 2
gmake[1]: Leaving directory `/usr/local/src/mozilla/mozilla/obj-opt'
gmake: *** [distclean] Error 2

Comment 1

17 years ago
dmose, playing well with objtrees is a universal build requirement.  Can you fix
this or do we need to switch it over to using autoconf?
Assignee: cls → dmose

Comment 2

17 years ago
you assigned this to the wrong dmose account. he uses dmose@mozilla.org
Assignee: dmose → dmose
(Assignee)

Comment 3

17 years ago
The code is already autoconfified, and generally supports objtrees (I build in
one), so this is just a bug, I think.

David, are you using --enable-nspr-autoconf with your toplevel configure?
(Reporter)

Comment 4

17 years ago
dmose, I get the error when using --enable-nspr-autoconf in my .mozconfig.  If I
don't use that option then it works fine.
(Assignee)

Comment 5

17 years ago
Reassigning to XPCOM SDK / C SDK bug to Leif.
Assignee: dmose → leif

Comment 6

17 years ago
Ok. I hit this as well.  The problem is that ldap relies upon nspr's config
system and on a distclean nspr's autoconf.mk is removed before we hit this
point.  ldap should *not* depend upon another module's build system.

Updated

17 years ago
Keywords: mozilla0.9

Comment 7

17 years ago
I see this even without using --enable-nspr-autoconf in my .mozconfig file. Is
there an easy workaround?

Comment 8

17 years ago
Workaround: build in a separate objdir and remove the entire objdir instead of
bothering with a distclean.

NSPR autoconf is the default now so people will always hit this if they do a
distclean.

Comment 9

17 years ago
Created attachment 30051 [details] [diff] [review]
One more hack for the non-existant ldap build system
(Assignee)

Comment 10

17 years ago
The real fix for this happpens when we move to the LDAP C SDK 5.0 (probably post
0.9.1).  However, as a temporary hack, we could extend the idea behind cls'
patch even further, and simply check in a copy of nspr/{build,config} locally
into directory/c-sdk/ldap/build on the LDAPCSDK_40_BRANCH and make at least the
autoconf build system point to that.  That would also fix the fact that building
with a system copy of NSPR is currently broken.  Thoughts?

Comment 11

17 years ago
Created attachment 30113 [details] [diff] [review]
Updated distclean hack that works in both srcdir & objdir and actually removes the generated files

Comment 12

17 years ago
Well, if the consensus is to "copy" those NSPR files into the C-SDK (v4.0) build
directory, I can look into that.
Status: NEW → ASSIGNED
(Assignee)

Comment 13

17 years ago
r=dmose@netscape.com for cls' fix so that that can tide us over until leif gets
copies of the nspr files checked in.  Thanks Chris!

Comment 14

17 years ago
Giving this bug to dmose.
Assignee: leif → dmose
Status: ASSIGNED → NEW
Keywords: mozilla0.9 → mozilla0.9.1, nsbeta1
Summary: Distclean fails in directory/c-sdk/ldap → --enable-nspr-autoconf busted by LDAP C SDK buildsystem
Target Milestone: --- → mozilla0.9.1

Updated

17 years ago
Target Milestone: mozilla0.9.1 → mozilla0.9.2
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.2 → mozilla0.9.3

Comment 15

17 years ago
Marking Mozilla 1.0.
Target Milestone: mozilla0.9.3 → mozilla1.0

Updated

16 years ago
Blocks: 104166
(Assignee)

Comment 16

16 years ago
This should actually be fixed as part of the move to a newer version of the LDAP
C SDK.
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.8
(Assignee)

Updated

16 years ago
Target Milestone: mozilla0.9.8 → mozilla0.9.9

Updated

16 years ago
Target Milestone: mozilla0.9.9 → mozilla1.2
(Assignee)

Comment 17

16 years ago
I suspect this is fixed, now that we've switched to the 5.0 C SDK.  Can anyone
confirm?
Yes, |make -f client.mk distclean| has worked for awhile now.
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.