enable memcache, remove dead sections, fix logging in accountportal configs

RESOLVED FIXED

Status

Cloud Services
Server: Other
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: atoll, Assigned: telliott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [accountportal])

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
the accountportal staging configs don't work very well for logging or memcache yet, and there's apparently a lot of dead options that have no relevance.  could you please merge the logging from keyexchange configs so we get working syslog/CEF and in general help me get them into a working state?
(Assignee)

Comment 1

7 years ago
Created attachment 507299 [details]
Production config

I believe this should work as the production.ini
Attachment #507299 - Flags: review?(tarek)
Attachment #507299 - Flags: feedback?(rsoderberg)
(Assignee)

Comment 2

7 years ago
Created attachment 507305 [details]
account portal production config file
Attachment #507305 - Flags: review?(tarek)
Attachment #507305 - Flags: feedback?(rsoderberg)
(Assignee)

Comment 3

7 years ago
Created attachment 507308 [details]
And the core config that accountportal config refers to
Attachment #507308 - Flags: review?(tarek)
Attachment #507308 - Flags: feedback?(rsoderberg)
(Reporter)

Comment 4

7 years ago
Comment on attachment 507299 [details]
Production config

please compare to keyexchange production.ini and indicate where the logging configuration differs, if any.  would be good to understand anything that's not logging filename.
Attachment #507299 - Flags: feedback?(rsoderberg) → feedback+
(Reporter)

Comment 5

7 years ago
Comment on attachment 507305 [details]
account portal production config file

"servces" -> "services"

do we have translations now, or at least an english translation, so that trans_dir is useful?  how do we specify a relative path for trans_dir, or alternately where are the files on disk?

session timeout - 500 seconds? 500 milliseconds?  is this a timeout for memcache response, or a timeout for the sessions within memcache when idle?
(Assignee)

Comment 6

7 years ago
(In reply to comment #5)
> Comment on attachment 507305 [details]
> account portal production config file
> 
> "servces" -> "services"
> 
> do we have translations now, or at least an english translation, so that
> trans_dir is useful?  how do we specify a relative path for trans_dir, or
> alternately where are the files on disk?
> 

we don't yet use trans_dir, since I'm still doing some work on the translations. I left it in to remind us that we'd need it eventually.

I'm thinking it should be set to /etc/mozilla-services/accountportal/locale, since that seems a likely place that we'll drop translations.


> session timeout - 500 seconds? 500 milliseconds?  is this a timeout for
> memcache response, or a timeout for the sessions within memcache when idle?

This is how long a session is valid for, and is in seconds.
(Reporter)

Comment 7

7 years ago
Comment on attachment 507308 [details]
And the core config that accountportal config refers to

remove the trailing ' from syslog.options?

please verify that [cef] section settings match the keyexchange (working) settings, they should be equivalent except for product (which is not in this file)

can we reconfigure [auth] to use cache.type = ext:memcached?  is this [auth] cache section in use anywhere else?  i think it's beaker caching, but maybe it's dead code?

we will adjust bind_user/admin_user as needed to fit the needed deployment.  accountportal is going to be a reg-class, so it will be bind user only.  are we permitted to remove admin_user entirely?
Attachment #507308 - Flags: feedback?(rsoderberg) → feedback-
(Reporter)

Updated

7 years ago
Attachment #507305 - Flags: feedback?(rsoderberg) → feedback+
(Assignee)

Comment 8

7 years ago
(In reply to comment #7)
> Comment on attachment 507308 [details]
> And the core config that accountportal config refers to
> 
> remove the trailing ' from syslog.options?
> 
> please verify that [cef] section settings match the keyexchange (working)
> settings, they should be equivalent except for product (which is not in this
> file)
> 
Attaching a revised core.cfg that uses the keyexchange one (except for product, which is defined in accountportal.cfg)

> can we reconfigure [auth] to use cache.type = ext:memcached?  is this [auth]
> cache section in use anywhere else?  i think it's beaker caching, but maybe
> it's dead code?
> 

I actually don't know what these three are for, and can't find anything in server-core that refers to it. Tarek, any idea?

> we will adjust bind_user/admin_user as needed to fit the needed deployment. 
> accountportal is going to be a reg-class, so it will be bind user only.  are we
> permitted to remove admin_user entirely?

Also a question for Tarek.
(Assignee)

Comment 9

7 years ago
Created attachment 507320 [details]
core config v2
Attachment #507308 - Attachment is obsolete: true
Attachment #507320 - Flags: review?(tarek)
Attachment #507320 - Flags: feedback?(rsoderberg)
Attachment #507308 - Flags: review?(tarek)
(In reply to comment #8)
> > can we reconfigure [auth] to use cache.type = ext:memcached?  is this [auth]
> > cache section in use anywhere else?  i think it's beaker caching, but maybe
> > it's dead code?
> > 
> 
> I actually don't know what these three are for, and can't find anything in
> server-core that refers to it. Tarek, any idea?

dead config, to be removed

> 
> > we will adjust bind_user/admin_user as needed to fit the needed deployment. 
> > accountportal is going to be a reg-class, so it will be bind user only.  are we
> > permitted to remove admin_user entirely?
> 
> Also a question for Tarek.

No (but it's easy to change this -- we can add a bug about this) 

admin_user should stay for now and be a duplicate of bind_user

Updated

7 years ago
Attachment #507299 - Flags: review?(tarek) → review+
Comment on attachment 507305 [details]
account portal production config file

>[DEFAULT]

Typo, misses a 'i'

>extends = /etc/mozilla-servces/core.cfg
>
>[console]
>prefix =
>static_url_root = /account_static

A personal path feels weird in the commited repository

>trans_dir = /Users/telliott/mozilla/weave/account-portal/locale/
>modules = account
>          sync
>
>[smtp]
>host = localhost
>port = 25
>sender = weave@mozilla.com

No need to add those if you don't auth. on the smtp server

>user =
>password =
>
>[session]
>type = ext:memcached
>url = localhost:11211
>secure = False
>timeout = 500
>key = console
>encrypt_key = needtogetasecretoutofconfig

typo 

>valdidate_key = someotherstring
>lock_dir = /tmp
>
>[sync]
>quota_request_file = /tmp/quota_requests
>
>[cef]
>product = portal
Comment on attachment 507320 [details]
core config v2

as said in the comments, cache. can be removed
Attachment #507320 - Flags: review?(tarek) → review+
(Assignee)

Comment 13

7 years ago
(In reply to comment #11)
> Comment on attachment 507305 [details]

> >[smtp]
> >host = localhost
> >port = 25
> >sender = weave@mozilla.com
> 
> No need to add those if you don't auth. on the smtp server
> 
> >user =
> >password =


I think it's good to leave them in the repo, because it lets ops know that it's a configuration option for them.
(In reply to comment #13)
> (In reply to comment #11)
> > Comment on attachment 507305 [details]
> 
> > >[smtp]
> > >host = localhost
> > >port = 25
> > >sender = weave@mozilla.com
> > 
> > No need to add those if you don't auth. on the smtp server
> > 
> > >user =
> > >password =
> 
> 
> I think it's good to leave them in the repo, because it lets ops know that it's
> a configuration option for them.

I'd rather have them commented out in that case 

# user used to authenticate to the SMTP server
# user = someone

because the configuration reader makes a difference between "no option given" and "the option value is an empty string."
(Assignee)

Comment 15

7 years ago
That's reasonable
(Assignee)

Comment 16

7 years ago
Cleaned up in http://hg.mozilla.org/services/account-portal/rev/0682282c5c8f and http://hg.mozilla.org/services/account-portal/rev/ff1c8a1190c2
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Attachment #507320 - Flags: feedback?(rsoderberg) → feedback+
(Assignee)

Updated

7 years ago
Attachment #507305 - Flags: review?(tarek)
You need to log in before you can comment on or make changes to this bug.