All users were logged out of Bugzilla on October 13th, 2018

Stop script popup not coming up. Error console shows no errors. Had to ctrl+alt+del firefox.exe.

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: noitidart, Unassigned)

Tracking

4.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

This locked up the browser completely. I thought the other tabs were not supposed to crash. Error console had nothing in it. The error seen in the image I attached happend before the javascript lockup.
I have uploaded the image here: http://img.photobucket.com/albums/v135/noitidart/stopscripterror.jpg

Reproducible: Always

Steps to Reproduce:
1. Download new tab king addon https://addons.mozilla.org/en-US/firefox/addon/new-tab-king/
2. Start typing in the to do list box
3. When browser freezes, after a minute you will get this popup box trying to popup but it doesnt, and even the X is not clickable of the popup box.
Actual Results:  
Popup box tried to open but wouldn't. Error console showed no errors. Locked up everything.

Expected Results:  
Error console should also show the errors. Stop script should come up and be clickable. I thought with putting the JS into it's own plugin-container.exe that the JS crashing should not crash the browser or other tabs, I thought this was a major feature and would really love it. Please make the browser withstand this.

Comment 1

8 years ago
Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110126 Firefox/4.0b11pre

Works fine for me. Please try if it works fine by creating a new profile
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 2

8 years ago
I couldn't recreate the problem on a clean profile. Maybe its another addon interfering. Thanks and sorry about this.

Comment 3

7 years ago
Reporter -> Are you still experiencing this issue? Have you tried safe mode or a new profile? Did you find an extension at fault?
(Reporter)

Comment 4

7 years ago
Sorry I haven't tried. I'm desperately trying to get help for my addon. I'll try to help here too.

Comment 5

7 years ago
Any update? Closing bug as extension compatibility - feel free to post back if you find the one at fault
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Extension Compatibility
QA Contact: general → extension.compatibility
Resolution: --- → INVALID
Version: Trunk → 4.0 Branch
You need to log in before you can comment on or make changes to this bug.