Invalid "This body part will be downloaded on demand" in IMAP account

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
8 years ago
6 years ago

People

(Reporter: emoore, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.0; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Thunderbird 3.0.11 ID:20101125144718

I share a profile with Thunderbird 3.0.11, 3.1.7, Shredder, and Miramar 3.3a2. mail.imap.mime_parts_on_demand is set false. I've also disabled global search/indexing and IMAP offline folders. 

In my Fastmail.fm IMAP account (which uses a Cyrus IMAP server) I tried to read a message and saw "This body part will be downloaded on demand." instead of the message body. The message displays a Part1.2 attachment icon at the bottom. I was able to double click on that and read its contents. I was also able to read the message source using either Control-U or view -> message source. That worked regardless of whether or not I opened the attachment. Reading the attachment and/or the message source didn't load the message body.

I see this problem when running in safe mode too. I had no problem copying the message to "Local Folders" and viewing it there. I then copied the message back to the Fastmail.fm IMAP account inbox and ran into the problem.  

I copied the message to a Gmail , Axigenmail.com, aim.com, and a gmx.com IMAP account. Each had the same problem. I then copied it to my lavabit.com IMAP account. It displayed the message. I copied it to my zoho.com IMAP account. It didn't displayed anything in the message body, even after I used control-U to view the message source. However, when I tried it again several minutes later it didn't have the problem.

Lavabit.com and Zoho.com provide free IMAP accounts.

I don't have this problem with 3.1.7, Shredder (Thunderbird 3.3a3pre ID:20110127030124) or Miramar 3.3a2. 

I realize this problem doesn't occur with the latest release but I thought I'd file this bug report as I've run into similar problems with 3.1.7 that I could not reproduce. This one is 100% reproducible on my system. I'm using Vista SP2. 

The message had a multipart/mixed; Content-Type and a S/MIME signature.


Reproducible: Always
(Reporter)

Comment 1

8 years ago
Created attachment 507475 [details]
Message that caused "This body part will be downloaded on demand" problem in certain IMAP accounts

Comment 2

8 years ago
> mail.imap.mime_parts_on_demand

You will need mail.server.default.mime_parts_on_demand="false" instead if you want to disable downloading MIME parts separately. The message parts exceed the 30k threshold, thus I'd expect them to be downloaded on demand. The potentially tricky thing may be the message's structure, where the electronic signature only relates to some inner parts with the message itself being extended by the mailing-list additions. I don't know enough about those signatures to determine if this could contribute to the problem.

The download-on-demand behavior should have changed in 3.1.8 (bug 565852), but that should also be visible in 3.3a2 already.

Updated

8 years ago
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap

Comment 3

7 years ago
rsx11m, are you saying that Eric should find this to be fixed in version 5 or newer?

Comment 4

7 years ago
Maybe, but maybe not. The mime_parts_on_demand stuff seems to have changed somewhere again, thus I don't know how well it works around any issues Eric encountered.

Comment 5

6 years ago
Eric, does this occur in current versions of Thunderbird?
Flags: needinfo?(tanstaafl)
(Reporter)

Comment 6

6 years ago
Both mail.imap.mime_parts_on_demand and mail.server.default.mime_parts_on_demand are false. I haven't seen this problem with recent versions of Thunderbird, with any of my accounts. I'd assume it was fixed in 3.1.7.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(tanstaafl)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.