Print previewing an email with an attachment requires user to have to open it twice

RESOLVED DUPLICATE of bug 529210

Status

MailNews Core
Networking: IMAP
--
major
RESOLVED DUPLICATE of bug 529210
7 years ago
5 years ago

People

(Reporter: Ian Neal, Unassigned)

Tracking

1.9.1 Branch
x86
Windows Server 2003

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Steps to reproduce.
1/ Connect to an IMAP mail server.
2/ Select a message with a word or excel attachment.
3/ Select print preview.
4/ Progress dialog comes up.

Expected result.
1/ Print preview window opens.

Actual result.
1/ Stays stuck on progress dialog window.

Workaround
1/ Close progress dialog window.
2/ Select print preview.
3/ Progress dialog opens.
4/ Dialog closes and preview window opens.

Comment 1

7 years ago
Ian, which SM version are you using? This seems to be bug 529210 which was fixed by bug 565852 and should be visible on trunk or the 2.0.12 candidates.
(Reporter)

Comment 2

7 years ago
(In reply to comment #1)
> Ian, which SM version are you using? This seems to be bug 529210 which was
> fixed by bug 565852 and should be visible on trunk or the 2.0.12 candidates.

Hmmm, I did search but didn't hit the right combination of words obviously. The 400+ users all have 2.0.11, so once 2.0.12 is out I'll confirm that this is fixed and mark this bug as a dupe.
(Reporter)

Updated

7 years ago
Version: unspecified → 1.9.1 Branch

Comment 3

6 years ago
(In reply to Ian Neal from comment #2)
> (In reply to comment #1)
> > Ian, which SM version are you using? This seems to be bug 529210 which was
> > fixed by bug 565852 and should be visible on trunk or the 2.0.12 candidates.
> 
> Hmmm, I did search but didn't hit the right combination of words obviously.
> The 400+ users all have 2.0.11, so once 2.0.12 is out I'll confirm that this
> is fixed and mark this bug as a dupe.

Ian, all better now? :)

Comment 4

6 years ago
Caching of attachments is still broken for IMAP without synchronization enabled due to bug 629738, but should cause only unnecessary re-fetching rather than a hang.
(In reply to rsx11m from comment #4)
> Caching of attachments is still broken for IMAP without synchronization
> enabled due to bug 629738, but should cause only unnecessary re-fetching
> rather than a hang.

I read that and the history of this bug as saying that it's a duplicate of bug 529210 which was fixed at the time. STR aren't complete.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 529210
You need to log in before you can comment on or make changes to this bug.