scroll bar wont work with mouse scrolling




7 years ago
5 years ago


(Reporter: firefox, Unassigned)



Firefox Tracking Flags

(Not tracked)




7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b9) Gecko/20100101 Firefox/4.0b9

Starting with FF 4 Beta 7, the scroll bar at the right hand side wont respond to scroll events from a mouse. One has to point the mouse pointer on the scroll bar and pull it up/down with a left click on the mouse.

The scroll bar inside a webpage (just as the one that you have in the "Component" row of this page is also not responding)

All other major browsers like Chrome, IE and Opera respond to mouse scroll events properly.

I have cleared the cache and cookies, started in safe mode... but nothing works. No google toolbar and most of the add-ons are disabled in FF 4 beta versions. Some are still running though. But I dont think the problem has anything to do with the third party add-ons installed.

Reproducible: Always

Steps to Reproduce:
1. Open any webpage which is larger than one screen size.
2. Try to scroll up or down with mouse scroll pointer.
Actual Results:  
Scrolling does not happen

Expected Results:  
Browser should respond to scroll events from the mouse.

I have tried with the default theme, different themes installed. No change in the behavior.


7 years ago
Version: unspecified → Trunk


7 years ago
Severity: normal → major
Priority: -- → P2

Comment 1

7 years ago
I too can confirm this bug in 4.0b10. However, I have found the other reason. If there is pdf opened in one of the tabs, scrolling wont work, although even mousepointer for scrolling appears.
I am using Win7 x64 and synaptics.


7 years ago
Severity: major → critical
Works For Me on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110207 Firefox/4.0b12pre, even with a pdf file open in another tab.
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME

Comment 3

7 years ago
Can you please provide the link where i can download the overnight builds for testing?
Alex, like in bug 635709 and bug 628954, it seems like the resolution was changed a bit too pre-emptively to WORKSFORME. Just because one person reports WFM, doesn't mean there isn't a bug. It would be helpful to get the reporter to try with safe mode/clean profile/latest nightly first, before marking worksforme - and only if they don't respond, mark as incomplete a few weeks later.

Reporter, please can you try with the latest nightly from:
...and also with a clean profile:
Resolution: WORKSFORME → ---


7 years ago
Severity: critical → major
Priority: P2 → --

Comment 5

7 years ago
Downloaded the nightly build. Installed it.

1. I still see the same problem with the default profile.

2. Exit the nightly install and create a new profile for the same. Start the browser. Still the same result

3. Exit the nightly install. Create a new profile for FF 4 beta 11 already installed on my system -> start firefox -> scroll bar still DOES NOT WORK.

I reported this bug for 2 reasons:-

1. I have been experiencing the same behaviour on my laptop (Lenovo T60p) and also my Desktop running on Win XP.

2. I also have FF 3.x latest also installed on my laptop. The scrolling works perfectly well when I use that. So both FF 4 beta and FF 3.x are running in the exact same environment.
OS: Windows XP → All
Could you find the regression range please:
Keywords: regression, regressionwindow-wanted

Comment 7

7 years ago
for the pdf issue see Bug 315513 and Bug 627275
firefox, is this still an Issue for you using a recent Firefox Version?
I couldn't reproduce this issue on Windows 7 x86, Ubuntu x32, and Mac OS 10.8 for FF4b7 and Latest Nightly (11.12.2012). Scroll bar works as expected for all.

Mozilla/5.0 (Windows NT 6.1; rv:2.0b7) Gecko/20100101 Firefox/4.0b7(20101104131838)
Mozilla/5.0 (Windows NT 6.1; rv:20.0) Gecko/20121211 Firefox/20.0(20121211030855)

Mozilla/5.0 (X11; Linux i686; rv:2.0b7) Gecko/20100101 Firefox/4.0b7(20101104125541)
Mozilla/5.0 (X11; Linux i686; rv:20.0) Gecko/20121211 Firefox/20.0(20121211030855)

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:2.0b7) Gecko/20100101 Firefox/4.0b7 (20101104131842)
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20121205 Firefox/20.0(20121205030759)
Last Resolved: 7 years ago5 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.