Save multiple messages at once as text or HTML files

UNCONFIRMED
Unassigned

Status

--
enhancement
UNCONFIRMED
8 years ago
2 years ago

People

(Reporter: john728, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101207 Mnenhy/0.8.3 Thunderbird/3.1.7

SaveAs allows saving an individual message as .eml, text, or HTML. Selecting multiple messages allows saving them as .eml files.  I want to be able to select multiple messages and then save them all at once as text or HTML files.  An extension called SmartSave supposedly does this but is incompatible with my version of Thunderbird.  This functionality should be integrated with Thunderbird anyway, so it is not dependent on extensions.

In the bug 364445 report, he wants to save multiple messages into a single file, so please don't mark this bug report as a duplicate of that.

Reproducible: Always

Steps to Reproduce:
1.Highlight a message.
2.Highlight one or more additional messages using shift- or control- click.
3.Click File > Save As > File.  Select a folder and click OK.
Actual Results:  
The files are saved in the .eml format.

Expected Results:  
A dialog box with a drop-down menu prompting to save as either .eml, .txt, or HTML.
Okay, I won't dupe it to 364445; how does this one look?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 263949
(Also note bug 58140)
(Reporter)

Comment 3

8 years ago
Actually, no, but bug 364445 should be marked as a dupe of bug 263949.  From bug 263949:

"I would love to see ... the ability to ... save multiple emails as one plain text file"

My bug is about saving multiple messages as multiple files.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
so you're bug 58140 :D Where the difference ?
(Reporter)

Comment 5

8 years ago
Bug 58140 addresses saving multiple messages.  It says nothing about saving multiple messages as HTML or text.
You need to log in before you can comment on or make changes to this bug.