Closed Bug 629679 Opened 9 years ago Closed 9 years ago

Flash wmode transparent show a black background

Categories

(Core :: Plug-ins, defect, major)

x86
Windows XP
defect
Not set
major

Tracking

()

RESOLVED DUPLICATE of bug 626602
Tracking Status
blocking2.0 --- final+

People

(Reporter: striptm, Assigned: jimm)

References

()

Details

(Keywords: regression, Whiteboard: [hardblocker])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre

A flash object with wmode=transparent show a black background instead of transparent background.
Tested on several windows xp without hardware acceleration and new profile.
The performance also is affected, Firefox works slowly if flash add animation.

Reproducible: Always

Actual Results:  
Object width black background

Expected Results:  
Object width transparent background

Shockwave Flash information:
    Archivo: NPSWF32.dll
    Versión: 10.1.102.64
    Shockwave Flash 10.1 r102
Keywords: regression
about:support

  Configuración básica de la aplicación

        Nombre
        Firefox

        Versión
        4.0b11pre

        Agente de usuario
        Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre

        Directorio de perfil

          Abrir la carpeta que lo contiene

        Plugins activados

          about:plugins

        Configuración de compilación

          about:buildconfig

  Extensiones

        Nombre

        Versión

        Activada

        ID

        Microsoft .NET Framework Assistant
        1.0
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        Java Quick Starter
        1.0
        true
        jqs@sun.com

  Preferencias modificadas

      Nombre

      Valor

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110127030333

        browser.startup.homepage_override.mstone
        rv:2.0b11pre

        extensions.lastAppVersion
        4.0b11pre

        network.cookie.prefsMigrated
        true

        places.history.expiration.transient_current_max_pages
        32144

        privacy.sanitize.migrateFx3Prefs
        true

  Gráficos

        Descripción del adaptador
        Radeon X300/X550/X1050 Series

        ID del fabricante
        1002

        ID del dispositivo
        5b63

        RAM del adaptador
        Unknown

        Controladores del adaptador
        ati2dvag

        Versión del controlador
        8.593.100.0

        Fecha del controlador
        2-10-2010

        Direct2D activado
        false

        DirectWrite activado
        false (0.0.0.0)

        Renderizador WebGL
        ATI Technologies Inc. -- Radeon X300/X550/X1050 Series -- 2.1.8545 Release

        Ventanas aceleradas mediante GPU
        0/1
Confirmed on XP with Fx4 beta 10 and Flash 10.1.102.64

I do not experience this bug on Linux.

This regression is likely to break a lot of sites, setting to major.
Severity: normal → major
Status: UNCONFIRMED → NEW
Ever confirmed: true
blocking2.0: --- → final+
Whiteboard: [hardblocker]
Jim, can you look into this, or does this seem more like bug for roc or bas? Feel free to reassign.
Assignee: nobody → jmathies
Depends on: 626602
(In reply to comment #5)
> Jim, can you look into this, or does this seem more like bug for roc or bas?
> Feel free to reassign.

This is a windowless control with alpha. I'd bet the work in bug 626602 will address this.
Similary with: bug 626206  ?
Depends on: 626206
#4 Pascal confirmed, no problem in Mozilla/5.0 (X11; Linux x86_64; rv:2.0b11pre) Gecko/20110127 Firefox/4.0b11pre
Shockwave Flash 10.2 d161 libflashplayer.so
(In reply to comment #9)
> Bug 626602 fixes this.

Would it be alright to dupe this over to get it out of the blocker lists?
I think so.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 626602
You need to log in before you can comment on or make changes to this bug.