Closed Bug 629718 Opened 9 years ago Closed 3 years ago

WinXP (WINNT 5.1) Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/tspan-rotate-01.svg, tspan-rotate-02.svg, tspan-rotate-03.svg, tspan-rotate-04.svg, tspan-rotate-05.svg, tspan-rotate-06.svg | image comparison (==)

Categories

(Core :: SVG, defect, P5)

x86
Windows XP
defect

Tracking

()

RESOLVED WONTFIX

People

(Reporter: philor, Unassigned)

References

Details

(Keywords: intermittent-failure)

Attachments

(2 files)

Attached file reftest log
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1296224234.1296225994.14161.gz
Rev3 WINNT 5.1 tracemonkey opt test reftest on 2011/01/28 06:17:14
s: talos-r3-xp-030

REFTEST TEST-START | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/tspan-rotate-02.svg
REFTEST TEST-UNEXPECTED-FAIL | file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/tspan-rotate-02.svg | image comparison (==)
...
REFTEST number of differing pixels: 44
REFTEST INFO | Saved log: START file:///C:/talos-slave/test/build/reftest/tests/layout/reftests/svg/tspan-rotate-02.svg
REFTEST INFO | Saved log: OnDocumentLoad triggering AfterOnLoadScripts
REFTEST INFO | Saved log: DoDrawWindow 0,0,800,1000
REFTEST INFO | Saved log: RecordResult fired
REFTEST INFO | Saved log: RecordResult fired
This failure is quite odd... In the testcase, the "c" is shifted up slightly, and the bow of the "b" is shifted down, rotated clockwise slightly, and broken open (cropped?) at its lower-right corner.

These letters have rotation 45+90 and -45+90 in the testcase.

The rest of the letters (who have rotation [0 or 180]+90) are fine.
Summary: Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/tspan-rotate-02.svg | image comparison (==) → Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/tspan-rotate-01.svg, tspan-rotate-02.svg, tspan-rotate-03.svg, tspan-rotate-04.svg, tspan-rotate-05.svg, tspan-rotate-06.svg | image comparison (==)
Duplicate of this bug: 635478
Duplicate of this bug: 636531
Duplicate of this bug: 636604
Duplicate of this bug: 637625
Summary: Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/tspan-rotate-01.svg, tspan-rotate-02.svg, tspan-rotate-03.svg, tspan-rotate-04.svg, tspan-rotate-05.svg, tspan-rotate-06.svg | image comparison (==) → WinXP (WINNT 5.1) Intermittent REFTEST TEST-UNEXPECTED-FAIL | layout/reftests/svg/tspan-rotate-01.svg, tspan-rotate-02.svg, tspan-rotate-03.svg, tspan-rotate-04.svg, tspan-rotate-05.svg, tspan-rotate-06.svg | image comparison (==)
Is this something we sometimes use a layer for?  If so, could we be having the problem of randomness related to when the timer for unlayerizing fires?
Per IRC discussion just now with ehsan, I think we should mark this test as random-on-winXP.

On the one hand, it seems to be a real bug that we ideally should investigate/fix (jfkthame - I'm looking at you, if you get some cycles! :)), but the rendering difference is pretty minimal, and it's limited to a legacy-ish platform, so it's probably not super high-priority.

The only thing making it high-priority right now is the randomorange pain that it's causing, and luckily we can fix that part with a random-on-WinXP annotation, while still preserving our test coverage on other platforms (on other windows platforms, even!)
Attachment #529025 - Flags: review?(ehsan)
Comment on attachment 529025 [details] [diff] [review]
mark tests as random-on-WinXP for now

r=me.  Thanks!
Attachment #529025 - Flags: review?(ehsan) → review+
Landed random-on-winXP annotation:
  http://hg.mozilla.org/mozilla-central/rev/ff152a406ed3
Whiteboard: [orange] → [orange][test marked random on winxp]
I guess we should mark it as random-on-winxp on aurora, too. (test-only change, so I think it should be ok to land without any special approval required (?))
I just pushed a cset (ea942f2caf48) to disable a different but very similar test in bug 645104.  I copied this bug's checkin comment for that commit, but I forgot to update the bug number in the checkin comment, so the checkin comment points here.  (the reftest.list annotation mentions the right bug number, though)  So, anyone who's directed here from cset ea942f2caf48 -- you really want bug 645104.
Whiteboard: [orange][test marked random on winxp] → [test marked random on winxp]
Priority: -- → P5
WONTFIXing, since this is WinXP-specific and we're desupporting XP as noted in bug 1315083 comment 0.

(Aryx is removing the reftest.list annotation for this failure in bug 1334898.)
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.