Last Comment Bug 629719 - Experiment with turning the UNREASONABLE_WORD_LENGTH limit for spell checker off in the nightlies
: Experiment with turning the UNREASONABLE_WORD_LENGTH limit for spell checker ...
Status: RESOLVED FIXED
: dev-doc-complete
Product: Core
Classification: Components
Component: Spelling checker (show other bugs)
: Trunk
: x86 Mac OS X
: -- normal with 2 votes (vote)
: ---
Assigned To: :Ehsan Akhgari
:
: Jet Villegas (:jet)
Mentors:
Depends on: 686497
Blocks: 340050
  Show dependency treegraph
 
Reported: 2011-01-28 10:23 PST by :Ehsan Akhgari
Modified: 2011-11-04 10:30 PDT (History)
11 users (show)
mounir: in‑testsuite?
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Patch (v1) (1.78 KB, patch)
2011-08-18 09:06 PDT, :Ehsan Akhgari
bugs: review+
Details | Diff | Splinter Review

Description :Ehsan Akhgari 2011-01-28 10:23:49 PST
We should see if turning off the protection added in bug 340050 still causes crashes...
Comment 1 :Ehsan Akhgari 2011-08-18 09:06:18 PDT
Created attachment 554108 [details] [diff] [review]
Patch (v1)
Comment 2 Olli Pettay [:smaug] 2011-08-20 09:09:21 PDT
Maybe Jesse or Martijn could try out some evil tests.
Comment 3 :Ehsan Akhgari 2011-08-22 13:49:57 PDT
(In reply to Olli Pettay [:smaug] from comment #2)
> Maybe Jesse or Martijn could try out some evil tests.

I'd love that, yes!
Comment 4 Mounir Lamouri (:mounir) 2011-08-23 01:33:09 PDT
http://hg.mozilla.org/mozilla-central/rev/3f728ae0066c
Comment 5 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-08-23 02:05:53 PDT
I don't know in what circumstances you would think it would crash. On long words, with the patch, it doesn't seem to crash anymore. But with the testcase from bug 334814, https://bugzilla.mozilla.org/attachment.cgi?id=219142 , it's still causing Mozilla to hang, having to kill it manually.
Comment 6 :Ehsan Akhgari 2011-09-12 15:04:07 PDT
(In reply to Martijn Wargers [:mw22] (QA - IRC nick: mw22) from comment #5)
> I don't know in what circumstances you would think it would crash. On long
> words, with the patch, it doesn't seem to crash anymore. But with the
> testcase from bug 334814,
> https://bugzilla.mozilla.org/attachment.cgi?id=219142 , it's still causing
> Mozilla to hang, having to kill it manually.

I can't reproduce that.  If you see this reliably, please file a new bug and include the STR.  Thanks!
Comment 7 Martijn Wargers [:mwargers] (not working for Mozilla) 2011-09-13 10:49:40 PDT
Ok, I filed bug 686497.
Comment 8 Eric Shepherd [:sheppy] 2011-11-04 10:30:54 PDT
This change has been listed in Firefox 9 for developers; the removed limitation had not been documented.

Note You need to log in before you can comment on or make changes to this bug.