mozilla.com needs updated sitelinks

RESOLVED FIXED in Future

Status

www.mozilla.org
General
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: morgamic, Assigned: Laura Forrest)

Tracking

unspecified
Future

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

8.60 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet
Details
(Reporter)

Description

8 years ago
http://www.sitemaps.org/protocol.php#informing

It's important, get it in the next milestone. *

* because I said so.

Just kidding.  Here:
http://www.google.com/#sclient=psy&hl=en&q=firefox&aq=f&aqi=&aql=&oq=&pbx=1&fp=d9008d84f286047

Basically, if someone searches for firefox or mozilla on google, the sitemap gives them a decent way to breakdown the site and choose a keyword/prominent page related to the top result.  Since we can actually control this, we should make it work properly and point people to pages that are most likely to match up with what they were originally looking for.

One thing we could do is make the sitemap.xml point to the 6 most popular pages or pages that correspond to the 6 or 8 top keywords used to search our domain.

Comment 1

8 years ago
+1
(Assignee)

Updated

8 years ago
Blocks: 629778
(Assignee)

Comment 2

8 years ago
(In reply to comment #0)
>One thing we could do is make the sitemap.xml point to the 6 most popular pages
>or pages that correspond to the 6 or 8 top keywords used to search our domain.

+1

Morgamic - I can provide these details.
Assignee: nobody → lforrest

Comment 3

8 years ago
For clarification, is this a mozilla.com or mozilla.org bug?  The first search result for 'Mozilla' in Google comes up with mozilla.org.  In the medium-term this isn't an issue
Summary: mozilla.com needs an updated sitemap → mozilla.com and mozilla.org needs an updated sitemap

Comment 4

8 years ago
Re, comment #3, the bug got submitted before I was finished...

Anyway, does it make sense to have one updated sitemap in the short-term on both mozilla.com and mozilla.org that covers the key pages on both sites?  Or should we update the sitemaps for both sites separately for now and re-do things after the sites merge?
bug 629778 or bug 629786 is the bug for mozilla.org
Summary: mozilla.com and mozilla.org needs an updated sitemap → mozilla.com needs an updated sitemap

Comment 6

8 years ago
Reed, I know there are separate bugs for the mozilla.org sitemap -- I was asking if we should consider those dupes and create one sitemap that covers content on both sites.
I think there is a misconception here about what is what in Google jargon.

Sitelinks : The "quick access links" shown below a result on Google.
Sitemaps : An XML file to help Google (and other search engines) crawl your website.

There is no clear way to modify Sitelinks. The algorithm is not explained, Google just says it tries to display relevant links. This might come from a clear hierarchy but it's not clear what Google calls a clear hierarchy.

The only sure thing we can do is remove one link. Note that this won't put another one in replacement. If you have 6 sitelinks, you'll get only 5 after removing one.

Resources:
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=47334
http://stackoverflow.com/questions/475779/how-to-get-sitelinks-to-appear-on-google-search
http://www.google.com/support/webmasters/bin/answer.py?hl=en&answer=156184
(Assignee)

Comment 8

8 years ago
Thanks Anthony - you're right, we can only control the sitelinks by blocking them. But we can also add "other information" to URLs we select (http://www.google.com/support/webmasters/bin/answer.py?answer=71936), including ranking them based on how important they are. 

From Google: "Setting the priority of pages will never affect your site's ranking in Google search results. Search engines use this information when selecting between URLs on the same site, so you can use this tag to increase the likelihood that your more important pages are present in a search index."

That info for our top 10 pages is attached. 

Lets be sure to not just add this additional information to a old sitemap, but to also generate and submit the latest and greatest sitemap. 

Curious - who has access to our Webmaster Tools?
(Assignee)

Comment 9

8 years ago
Created attachment 509343 [details]
Page Priority
(Assignee)

Comment 10

8 years ago
Anthony - Can you work on this? If all that's needed is access to Google Webmaster I'd be happy to make these changes directly.
Assignee: lforrest → nobody
(In reply to comment #8)
> Thanks Anthony - you're right, we can only control the sitelinks by blocking
> them. But we can also add "other information" to URLs we select
> (http://www.google.com/support/webmasters/bin/answer.py?answer=71936),
> including ranking them based on how important they are.
No we can't do that and that's what your quote from Google explains.

A sitemap is used to tell the crawler (the bot that visits every page) the URL of some pages, the last modification date, the frequency of updates to expect. The priority parameter is only there to tell "ok, if you don't have time to crawl everything, crawl this first". But it doesn't mean "put this page before this page in your ranking". Crawling and ranking are completely separated things. You have some control over Googlebot for the crawling (with robots.txt, sitemap.xml and Webmaster Tools) but you can't tell it how to do the ranking.

> That info for our top 10 pages is attached. 
> 
> Lets be sure to not just add this additional information to a old sitemap, but
> to also generate and submit the latest and greatest sitemap. 
Currently, we do not have a sitemap.

> Curious - who has access to our Webmaster Tools?
I will submit a patch to get ownership of it and then I'll be able to give access to others.
(Assignee)

Updated

8 years ago
Assignee: nobody → anthony
Committed r82047 to trunk and r82048 to stage.
(Assignee)

Updated

8 years ago
Target Milestone: 1.2 → 1.3
pushed to production r83056

also moving to 1.4 as this bug still needs more action
Target Milestone: 1.3 → 1.4

Updated

7 years ago
Duplicate of this bug: 637398
OK, I now have access to mozilla.com webmaster tools. If someone wants access, send me an email that is a google account so I can add you.
(Assignee)

Comment 16

7 years ago
In general there's a lot that can be done to improve the SEO of our sites. I'd like to keep the focus of this bug to improving the Sitelinks that appear for our natural search terms, which it sounds like Morgamic was originally referring to. For example, "Mozilla" returns a link to the 3.1 Beta. Lets think how we handle older site content like this in the eyes of the search engine (using no-follow or the like).  I'll change the title accordingly. "Site maps" can be handled in a different bug if deemed necessary. 

Both Chrissie and I should have been added to webmaster tools. To access, go here: https://www.google.com/webmasters/tools/dashboard?hl=en&siteUrl=http://www.mozilla.com/

Assigning this to Chrissie for now and placing in the 2.0 release.
Assignee: anthony → cbrodigan
Summary: mozilla.com needs an updated sitemap → mozilla.com needs updated sitelinks
Target Milestone: 1.4 → 2.0
I can confirm the whatsnew sitelink is not displayed anymore.

I've just blocked the "4 RC" sitelink that caught timeless's attention.
(Assignee)

Updated

7 years ago
Target Milestone: 2.0 → 2.1
(Assignee)

Updated

7 years ago
Target Milestone: 2.1 → 2.2
(Assignee)

Updated

7 years ago
Target Milestone: 2.2 → 2.3
(Assignee)

Updated

7 years ago
Target Milestone: 2.3 → Future

Comment 18

7 years ago
Hey Laura,

Think we can close this one down now as resolved?

Best,
CB
Assignee: cbrodigan → lforrest
(Assignee)

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Component: www.mozilla.org/firefox → www.mozilla.org
Product: Websites → Websites
Component: www.mozilla.org → General
Product: Websites → www.mozilla.org
You need to log in before you can comment on or make changes to this bug.