No hardware acceleration on WinXP and even no proof

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
8 years ago
7 years ago

People

(Reporter: Swapnilrustagi, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

No proof of hardware accelaration on Windows XP. I want proof because Mozilla Hacks' Hardware Accelaration Stress Test shows 6-7 FPS only. I'm even more shocked because Google Chrome, a browser which does not have Hardware acceleration on Windows XP, also shows 6-7 FPS. So, if Mozilla were EVEN PARTIALLY accelerated, it must show 10-11 FPS(minimum) and more. 

Reproducible: Always

Steps to Reproduce:
1. Open Mozilla Hacks Hardware accelaration stress Test on WinXP.
2. Click "Test" button or "Start" button to start test.
3. If the FPS is low, then it is the problem.
Actual Results:  
The test shows 6-7 FPS.

Expected Results:  
The test should show 10-18 FPS.
Please post you Graphics Information you can get via about:support resp. "Help"/"Troubleshooting Information".
(Reporter)

Comment 2

8 years ago
This is the info-


  Application Basics

        Name
        Firefox

        Version
        4.0b10

        User Agent
        Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Java Quick Starter
        1.0
        true
        jqs@sun.com

        Adblock Plus
        1.3.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

        Norton Safe Web Lite Toolbar
        1.2.0
        true
        {203FB6B2-2E1E-4474-863B-4C483ECCE78E}

        Add-on Compatibility Reporter
        0.7
        true
        compatibility@addons.mozilla.org

        Norton IPS
        2.0
        true
        {BBDA0591-3099-440a-AA10-41764D9DB4DB}

        FoxTab
        1.4.1
        true
        {ef4e370e-d9f0-4e00-b93e-a4f274cfdd5a}

        Feedback
        1.0.4
        true
        testpilot@labs.mozilla.com

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage
        http://www.google.co.in/

        browser.startup.homepage_override.buildID
        20110121161358

        browser.startup.homepage_override.mstone
        rv:2.0b10

        extensions.checkCompatibility
        false

        extensions.checkCompatibility.3.6
        false

        extensions.checkCompatibility.3.6b
        false

        extensions.checkCompatibility.3.6p
        false

        extensions.checkCompatibility.3.6pre
        false

        extensions.checkCompatibility.3.7a
        false

        extensions.checkCompatibility.4.0b
        false

        extensions.checkCompatibility.4.0p
        false

        extensions.checkCompatibility.4.0pre
        false

        extensions.lastAppVersion
        4.0b10

        network.cookie.prefsMigrated
        true

        network.http.pipelining
        true

        network.http.pipelining.maxrequests
        35

        places.database.lastMaintenance
        1296297455

        places.history.expiration.transient_current_max_pages
        13243

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        Intel(R) 82845G/GL/GE/PE/GV Graphics Controller

        Vendor ID
        8086

        Device ID
        2562

        Adapter RAM
        Unknown

        Adapter Drivers
        ialmrnt5

        Driver Version
        6.14.10.4342

        Driver Date
        6-21-2005

        Direct2D Enabled
        false

        DirectWrite Enabled
        false (0.0.0.0)

        WebGL Renderer
        (WebGL unavailable)

        GPU Accelerated Windows
        0/1
(In reply to comment #2)
>         Driver Version
>         6.14.10.4342
> 
>         Driver Date
>         6-21-2005

Please update your Driver and re-check.
(Reporter)

Comment 4

8 years ago
(In reply to comment #3)
> (In reply to comment #2)
> >         Driver Version
> >         6.14.10.4342
> > 
> >         Driver Date
> >         6-21-2005
> 
> Please update your Driver and re-check.

My driver is up-to-date because the Graphics card I have (Intel 82845G/GL/GE/GV...) is discontinued and  no updates are made.
(Reporter)

Comment 5

8 years ago
(In reply to comment #4)
> (In reply to comment #3)
> > (In reply to comment #2)
> > >         Driver Version
> > >         6.14.10.4342
> > > 
> > >         Driver Date
> > >         6-21-2005
> > 
> > Please update your Driver and re-check.
> 
> My driver is up-to-date because the Graphics card I have (Intel
> 82845G/GL/GE/GV...) is discontinued and  no updates are made.

I am giving my System Information
Operating System - Windows XP Service Pack 3
DirectX version - 9.0c 
OpenGL version supported - OpenGL 1.3
Processor - Intel Pentium 4
Graphics Memory - 64 MB
Graphics Card Support discontinued by Intel
Firefox version - Mozilla/5.0 (Windows NT 5.1; rv:2.0b10) Gecko/20100101 Firefox/4.0b10
(Reporter)

Comment 6

8 years ago
So, what I mean to say is that Firefox should accelerate using Direct3D 9 acceleration. I can say it's not accelerated because to see which application most recently used Direct3D, there is a registry key.
Registry Editor. Navigate My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Direct3D > MostRecentApplication. I never see "Firefox.exe" there.
(Reporter)

Comment 7

8 years ago
So, what I mean to say is that Firefox should accelerate using Direct3D 9 acceleration. I can say it's not accelerated because to see which application most recently used Direct3D, there is a registry key.
Registry Editor. Navigate My Computer > HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Direct3D > MostRecentApplication. I never see "Firefox.exe" there.
(Reporter)

Comment 8

8 years ago
I am waiting for a reply. Please help me.
It seems that your graphic card doesn't support the minimum features that Firefox requires for hardware acceleration.
(Reporter)

Comment 10

8 years ago
(In reply to comment #9)
> It seems that your graphic card doesn't support the minimum features that
> Firefox requires for hardware acceleration.

Could you please tell me which features. Well, my EVEREST Home Edition shows the following-
"Field	Value

Direct3D Device Properties	
Available Local Video Memory	59100 KB
Available Non-Local Video Memory (AGP)	0 KB
Rendering Bit Depths	16, 32
Z-Buffer Bit Depths	16, 24
Min Texture Size	1 x 1
Max Texture Size	2048 x 2048
Vertex Shader Version	Not Supported
Pixel Shader Version	Not Supported
	
Direct3D Device Features	
Additive Texture Blending	Supported
AGP Texturing	Not Supported
Anisotropic Filtering	Supported
Bilinear Filtering	Supported
Cubic Environment Mapping	Supported
Cubic Filtering	Not Supported
Decal-Alpha Texture Blending	Supported
Decal Texture Blending	Supported
Directional Lights	Not Supported
DirectX Texture Compression	Not Supported
DirectX Volumetric Texture Compression	Not Supported
Dithering	Supported
Dot3 Texture Blending	Supported
Dynamic Textures	Not Supported
Edge Antialiasing	Not Supported
Environmental Bump Mapping	Not Supported
Environmental Bump Mapping + Luminance	Not Supported
Factor Alpha Blending	Supported
Geometric Hidden-Surface Removal	Not Supported
Guard Band	Supported
Hardware Scene Rasterization	Not Supported
Hardware Transform & Lighting	Not Supported
Legacy Depth Bias	Not Supported
Mipmap LOD Bias Adjustments	Supported
Mipmapped Cube Textures	Supported
Mipmapped Volume Textures	Not Supported
Modulate-Alpha Texture Blending	Supported
Modulate Texture Blending	Supported
Non-Square Textures	Supported
N-Patches	Not Supported
Perspective Texture Correction	Supported
Point Lights	Not Supported
Point Sampling	Supported
Projective Textures	Not Supported
Quintic Bezier Curves & B-Splines	Not Supported
Range-Based Fog	Not Supported
Rectangular & Triangular Patches	Not Supported
Rendering In Windowed Mode	Supported
Scissor Test	Not Supported
Slope-Scale Based Depth Bias	Not Supported
Specular Flat Shading	Supported
Specular Gouraud Shading	Supported
Specular Phong Shading	Not Supported
Spherical Mapping	Not Supported
Spot Lights	Not Supported
Stencil Buffers	Supported
Sub-Pixel Accuracy	Supported
Table Fog	Supported
Texture Alpha Blending	Supported
Texture Clamping	Supported
Texture Mirroring	Supported
Texture Transparency	Supported
Texture Wrapping	Supported
Triangle Culling	Not Supported
Trilinear Filtering	Supported
Two-Sided Stencil Test	Not Supported
Vertex Alpha Blending	Supported
Vertex Fog	Supported
Vertex Tweening	Not Supported
Volume Textures	Not Supported
W-Based Fog	Supported
W-Buffering	Supported
Z-Based Fog	Supported
Z-Bias	Supported
Z-Test	Not Supported
	
Supported FourCC Codes	
I420	Supported
IMC1	Supported
IMC2	Supported
IMC3	Supported
IMC4	Supported
IYUV	Supported
UYVY	Supported
VYUY	Supported
YUY2	Supported
YV12	Supported
YVU9	Supported
YVYU	Supported
	
Problems & Suggestions	
Problem	Hardware Transform & Lighting is not supported. Modern 3D games may require it"

I also saw something strange-
Field	Value
DirectX Hardware Support	DirectX v6.0

Well, does that mean my graphics card is not capable of Hardware Acceleration.
(In reply to comment #10)
> Well, does that mean my graphics card is not capable of Hardware Acceleration.

The Requirements depend on e.g. the DirectX Support (>= 9.0), Driver Version and "Max Texture Size" (>= 4096). There may be others but your Cards fails on the mentioned ones.
Once Fx 4 is shipped those Requirements are to be mentioned in the Release Notes.

Updated

8 years ago
Version: unspecified → Trunk
Hardware acceleration is tricky. Sorry we don't support your card/driver combination, but we don't have the resources to make it work for everyone.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Component: General → Graphics
Product: Firefox → Core
QA Contact: general → thebes
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.