Part of the page isn't displayed correctly (works well under Firefox 3.6.15)

RESOLVED INVALID

Status

--
major
RESOLVED INVALID
8 years ago
3 years ago

People

(Reporter: kamil.stepinski, Unassigned)

Tracking

({regression, reproducible})

Details

(URL)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110120 Firefox-4.0/4.0b10pre
Build Identifier: Mozilla/5.0 (X11; Linux x86_64; rv:2.0b10pre) Gecko/20110120 Firefox-4.0/4.0b10pre

The 5 day forecast doesn't show up at all in Firefox 4 beta 10. It is displayed correctly when using Firefox 3.6.15
See screenshot:
http://picasaweb.google.com/kamil.stepinski/Misc#5567660367587019746

Reproducible: Always

Steps to Reproduce:
1.Navigate to the page: http://met.ie/forecasts/5day-ireland.asp
2.
3.
Actual Results:  
see the "Details" section

Expected Results:  
Display the page properly

Screenshot:
http://picasaweb.google.com/kamil.stepinski/Misc#5567660367587019746

Minefield 4.0b10pre (2011-01-20) on the left side
Namoroka 3.6.15pre on the right side
Regression range: 2009-12-01-03 -- 2009-12-02-03
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=b7f3c1c9fb57&tochange=a5e1b195ecf7

The tracemonkey merge seems the most likely culprit in that range.

There are a few DIVs containing the map content, all has display:none.
If I enter document.getElementById('rainfall').style.display='block'
in Tools->Web Console the map appears (at least some of it).
In a build where it works, this DIV has a style='display:block' attribute.
I'm guessing some script is responsible for loading/processing
some data and then adding this attribute to present it.

In 2009-12-02-03 (and trunk) I get this error in the Error Console:
Error: assignment to undeclared variable hours
Source File: http://met.ie/ssi/dateformatter24.js
Line: 83

In 2009-12-01-03 the error message is absent.
Keywords: regression, reproducible
The JS file has "use strict"; at the top and the tracemonkey merge
contained a few patches mentioning this feature so it could be an
error in the JS file...  http://met.ie/ssi/dateformatter24.js
The code clearly hasn't been tested in an ES5 implementation that supports strict mode -- understandably, since there haven't been any until recently, but that is good reason not to put "use strict"; at the top and make a wish.

This needs to be evangelized.

/be
Assignee: nobody → english-other
Status: UNCONFIRMED → NEW
Component: General → English Other
Ever confirmed: true
OS: Linux → All
Product: Firefox → Tech Evangelism
QA Contact: general → english-other
Hardware: x86_64 → All

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.