Previous update gets stuck when using a standard user account to update firefox or update presented to standard users

RESOLVED DUPLICATE of bug 629919

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 629919
7 years ago
5 years ago

People

(Reporter: Konomi, Unassigned)

Tracking

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110130 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110130 Firefox/4.0b11pre

Whenever I update firefox on a standard user account the previous update information is not cleared properly resulting in an apply now button always showing in help about.

Reproducible: Always

Steps to Reproduce:
1. Wait for an update of firefox
2. Update it on a standard user account
3. After the update is done go into help about and see the apply now button which should not be there
Actual Results:  
The update gets stuck until I go and delete it manually from C:\Users\<User>\AppData\Local\Mozilla\Firefox\Minefield

Expected Results:  
The update should be cleared after it's installed
(Reporter)

Updated

7 years ago
Summary: Previous update gets stuck when using a standard user account → Previous update gets stuck when using a standard user account to update firefox
Version: unspecified → Trunk
Dear Reporter, could you please try if it works in win7 x86, or any 32 bit OS? This will allow us to eliminate those and focus the problem to 64 bit system. 

I am asking for this because I cannot reproduce the issue on 

Mozilla/5.0 (Windows NT 6.1; rv:2.0b11pre) Gecko/20110130 Firefox/4.0b11pre 

Thanks!
(Reporter)

Comment 2

7 years ago
I was trying to test this with the next update but I'm being told to vista the web page to update my minefield in the about box on both my Win7 64bit machine and my WinXP 32bit machine. I'll test both as soon as this changes.
(Reporter)

Comment 3

7 years ago
I can now confirm this is happening on my Windows XP SP3 32bit OS on my EeePC as well. Same symptoms and same way to fix it deleting the mentioned folder.
(Reporter)

Comment 4

7 years ago
Additional follow up I was told that standard users or limited users should not be presented with the update option yet I am and it causes the above problem. Please see screenshot for details.
Summary: Previous update gets stuck when using a standard user account to update firefox → Previous update gets stuck when using a standard user account to update firefox or update presented to standard users
(Reporter)

Comment 5

7 years ago
Created attachment 514340 [details]
Standard user presented with update option

Comment 6

7 years ago
(In reply to comment #5)
> Created attachment 514340 [details]
> Standard user presented with update option

Window 7 32-bit system Firefox 4.0.0 RTM also tries to update to 4.0.1 while running as a standard user account, I do not have a screen shot, but could repeat the result as stated as filed.

Comment 7

7 years ago
This Error is also in Firefox 6.0.X 
Tested with standard user Win7 64bit

Comment 8

7 years ago
Created attachment 559237 [details]
Update bug in Firefox 6.02
(Reporter)

Comment 9

7 years ago
(In reply to vobexo from comment #8)
> Created attachment 559237 [details]
> Update bug in Firefox 6.02

Confirming this I still have this problem on v6.0.2 and I had to do the same thing described in my previous posts to fix the stuck update, I still don't know why this is not fixed considering updating is important and having it break for one user permently seems bad to me... Most users will never check help about and most will never know to delete the old update to be notified there is a new one...
Is this related to bug 629919?

Comment 11

6 years ago
(In reply to Gordon P. Hemsley [:gphemsley] from comment #10)
> Is this related to bug 629919?

Yes I think it is the same bug.

Comment 12

6 years ago
(In reply to vobexo from comment #11)
> (In reply to Gordon P. Hemsley [:gphemsley] from comment #10)
> > Is this related to bug 629919?
> 
> Yes I think it is the same bug.

an the bug is still alive in Firefox 12
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 629919

Comment 14

5 years ago
Bug is no more in Firefox 17.0 but is still in Thunderbird 17.0!
You need to log in before you can comment on or make changes to this bug.