Revenge of the unicode filenames

VERIFIED FIXED in 5.12.8

Status

addons.mozilla.org Graveyard
Public Pages
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: jbalogh, Assigned: jbalogh)

Tracking

Details

(Assignee)

Description

7 years ago
File "/data/amo_python/src/preview/zamboni/apps/addons/cron.py", line 245, in hide_disabled_files
   if os.path.exists(file_.file_path):
 File "/usr/lib64/python2.6/genericpath.py", line 18, in exists
   st = os.stat(path)
UnicodeEncodeError: 'ascii' codec can't encode characters in position 68-75: ordinal not in range(128)
(Assignee)

Updated

7 years ago
Target Milestone: 5.12.9 → 5.12.8
(Assignee)

Comment 1

7 years ago
https://github.com/jbalogh/zamboni/commit/51f88a9

This catches and logs the error, which is not a complete fix, but I couldn't reproduce the issue so it's all I've got.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 2

7 years ago
I uploaded and disabled an add-on with unicode in its name and didn't see any tracebacks.

Marking this as verified.
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.