`Print' toolbar button shouldn't have a menu

RESOLVED FIXED in Future

Status

SeaMonkey
UI Design
RESOLVED FIXED
17 years ago
10 years ago

People

(Reporter: Matthew Paul Thomas, Assigned: Doron Rosenberg (IBM))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DONTFIXME)

Attachments

(5 attachments)

(Reporter)

Description

17 years ago
Build: 2000121514, Mac OS 9.0

The `Print' button in the toolbar has a menu with one (1) item in it,
`Print ...'. The menu serves no purpose and should not exist.

Comment 1

17 years ago
And with more than one printer??
(Reporter)

Comment 2

17 years ago
What and with more than one printer what?
QA Contact: sairuh → claudius
Netscape nav triage team: as per Alec Flett's pre-triage recommendation, this 
bug is nsbeta1-.
Keywords: nsbeta1-
I take it this is a result of the comm build stripping of the Print Plus submenu?

Comment 5

17 years ago
we're supposed to have print setup, page setup and print preview. Don't remove 
the button.

mpt: stop filing bugs. it's ok for you to create specs and it's ok for you to 
advise about implementation and it's ok for you to tell us when we aren't 
meeting specs.  It is not ok for you to use bugzilla in this fassion.

recommend resolve wontfix/invalid.
Whiteboard: DONTFIXME
(Reporter)

Comment 6

17 years ago
No previous version of Netscape, and no version of Internet Explorer, has ever 
had toolbar buttons for Print Setup, or Page Setup, or Print Preview -- for the 
very good reason that none of them are used nearly often enough to deserve to 
be on the toolbar.

> Don't remove the button.

No, I didn't say the button should be removed, just the menu.

> mpt: stop filing bugs.

How amusing.
timeless: quit with the crack already. 

Comment 8

17 years ago
This should be fixed. Why is this mac only? I'll attach a patch in a sec, this
would be good and low risk enough to make 0.8.1 if drivers say ok. 

Comment 9

17 years ago
This is a first-round patch: 

Index: mozilla/xpfe/browser/resources/content/navigator.xul
=========================================================
==========
RCS file: /cvsroot/mozilla/xpfe/browser/resources/content/navigator.xul,v
retrieving revision 1.283
diff -u -2 -r1.283 navigator.xul
--- mozilla/xpfe/browser/resources/content/navigator.xul	2001/03/14 
03:05:08	1.283
+++ mozilla/xpfe/browser/resources/content/navigator.xul	2001/03/18 
00:08:29
@@ -180,7 +180,4 @@
       <menubutton class="menubutton-dual toolbar top" id="print-button" 
persist="hidden" value="&printButton.label;" 
                   crop="right" buttonaction="BrowserPrint()" tooltip="aTooltip" 
tooltiptext="&printButton.tooltip;">  
-        <menupopup id="printMenu" popupalign="topright" popupanchor=
"bottomright">
-          <menuitem value="&printCmd.label;" accesskey="&
printCmd.accesskey;" oncommand="BrowserPrint()" default="true"/>
-        </menupopup>
       </menubutton>
 

The problem is that it still keeps the little triangle there as if the menu 
were there. Looking for a way arround this.

Comment 10

17 years ago
I am so dumb. I missed the large MENU that's part of the tag. Try this:

Index: mozilla/xpfe/browser/resources/content/navigator.xul
=========================================================
==========
RCS file: /cvsroot/mozilla/xpfe/browser/resources/content/navigator.xul,v
retrieving revision 1.283
diff -u -2 -r1.283 navigator.xul
--- mozilla/xpfe/browser/resources/content/navigator.xul	2001/03/14 
03:05:08	1.283
+++ mozilla/xpfe/browser/resources/content/navigator.xul	2001/03/18 
00:14:21
@@ -178,10 +178,7 @@
       </hbox>
 
-      <menubutton class="menubutton-dual toolbar top" id="print-button" 
persist="hidden" value="&printButton.label;" 
+      <button class="menubutton-dual toolbar top" id="print-button" 
persist="hidden" value="&printButton.label;" 
                   crop="right" buttonaction="BrowserPrint()" tooltip="aTooltip" 
tooltiptext="&printButton.tooltip;">  
-        <menupopup id="printMenu" popupalign="topright" popupanchor=
"bottomright">
-          <menuitem value="&printCmd.label;" accesskey="&
printCmd.accesskey;" oncommand="BrowserPrint()" default="true"/>
-        </menupopup>
-      </menubutton>
+      </button>
 
       <hbox id="throbber-box" autostretch="never">

Comment 11

17 years ago
Forgot to hack the theme to not use menubutton rules for print any more. 

Index: mozilla/themes/modern/navigator/navigator.css
=========================================================
==========
RCS file: /cvsroot/mozilla/themes/modern/navigator/navigator.css,v
retrieving revision 1.38
diff -u -2 -r1.38 navigator.css
--- mozilla/themes/modern/navigator/navigator.css	2001/03/16 02:50:33	
1.38
+++ mozilla/themes/modern/navigator/navigator.css	2001/03/18 00:46:45
@@ -107,28 +107,23 @@
 }
 
+
 #print-button {
-  -moz-binding: url("chrome://communicator/skin/
widgetBindings.xml#menubutton-dual-1");
-  margin: 6px 6px 0px 6px;
   list-style-image: url("chrome://communicator/skin/btn1/print.gif");
 }
 
 #print-button[disabled="true"],
-#print-button[disabled="true"] > .menubutton-dual-stack > .menubutton-
dual-button:hover,
-#print-button[disabled="true"] > .menubutton-dual-stack > .menubutton-
dual-button:hover:active {
+#print-button[disabled="true"]:hover,
+#print-button[disabled="true"]:hover:active {
   list-style-image: url("chrome://communicator/skin/btn1/print-dis.gif");
 }
 
-#print-button > .menubutton-dual-stack > .menubutton-dual-button:hover 
{
-  list-style-image: url("chrome://communicator/skin/btn1/print-hov.gif");
+#print-button:hover {
+  list-style-image: url("chrome://navigator/skin/btn1/print-hov.gif");
 }
 
-#print-button > .menubutton-dual-stack > .menubutton-dual-
button:hover:active {
-  list-style-image: url("chrome://communicator/skin/btn1/print-act.gif");
+#print-button:hover:active {
+  list-style-image: url("chrome://navigator/skin/btn1/print-act.gif");
 }
 
-#print-button > .menubutton-dual-stack > .menubutton-dual-dropmarker-
box {
-  margin-left: 19px;
-  margin-top: 22px;
-}
 
 /* Hides text below the above buttons */

Comment 12

17 years ago
Created attachment 28013 [details] [diff] [review]
I suck and I pasted that in by mistake. Here is a full patch to fix.

Comment 13

17 years ago
Created attachment 28014 [details] [diff] [review]
Forgot to update classic. Also, I can just use <menubutton/> instead of </menubutton>

Comment 14

17 years ago
Hold off on this for now, it really breaks the skins. Trying to find out why?

Comment 15

17 years ago
Created attachment 28020 [details] [diff] [review]
Working patch. Note that the little triangle is still there. How do I get rid of it?
huzzah. a=ben

Comment 17

17 years ago
Created attachment 28022 [details] [diff] [review]
Finished and fully working patch!

Updated

17 years ago
Keywords: patch, review
Works great for me, and looks like solid work.

sr=shaver.

Comment 19

17 years ago
a=drivers

Comment 20

17 years ago
r=hwaara, let's land this baby!

Comment 21

17 years ago
This patch is: 

r=hwaara

sr=shaver

a=ben

branchapproval=drivers

It is ready to checkin and is tested and proven to fix this problem.
Wow, all this excitement for the removal of an almost empty drop down menu?
I'd can't wait to see your enthusiasm when we get ready to land the new view
manager or something like that! ;-)

Comment 23

17 years ago
Hixie: that is so funny I forgot to laugh. Note that the patch doesn't work,
don't check it in!

Comment 24

17 years ago
Marking nsbeta1- bugs future, though other than the patch not working, sounds
like we're close to fixing this. ;-)
Target Milestone: --- → Future
(Assignee)

Comment 25

17 years ago
Created attachment 29240 [details] [diff] [review]
nw patch
(Assignee)

Comment 26

17 years ago
new patch attached.  Perhaps a macperson can test if the mac classic is ok...

any comments? there were some double entries as well that I removed.

Comment 27

17 years ago
-> doron

Cc'ing alec to review his patch, if he can.
Assignee: ben → doronr
(Assignee)

Comment 28

17 years ago
This should be easy to get into 0.9

Status: NEW → ASSIGNED
Keywords: mozilla0.9
Target Milestone: Future → mozilla0.9

Comment 29

17 years ago
Netscape needs this for Print Plus.. I don't know who did that work but we need
to find a way to have no menu in the mozilla build, and a menu in the commercial
build.
(Assignee)

Comment 30

17 years ago
i'll talk to the build people and see how to do this, if possible at all.

Comment 31

17 years ago
it's totally possible with dynamic overlays, it has nothing to do with 'build
people' - the netscape commercial builds (including Netscape 6) already do this.
(Assignee)

Comment 32

17 years ago
my bad then, i thought it was just not checking into the commercial tree or
whatnot.  
(Assignee)

Comment 33

17 years ago
-> 1.0
Keywords: mozilla0.9 → mozilla1.0
Target Milestone: mozilla0.9 → mozilla1.0

Comment 34

17 years ago
Changing Platform/OS to all as this affects all systems.
OS: Mac System 8.5 → All
Hardware: Macintosh → All

Comment 35

17 years ago
*** Bug 86382 has been marked as a duplicate of this bug. ***

Comment 36

17 years ago
*** Bug 92032 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

16 years ago
Target Milestone: mozilla1.0 → Future

Comment 37

16 years ago
See also bug 111126, add "print preview" to this menu.

Comment 38

16 years ago
Now that bug 111126 has been checked in, doubling the number of items on the
menu, is this bug invalid?

Comment 39

16 years ago
adding self to cc list

Comment 40

16 years ago
am not complaining but...when u add urself to the cc list, u need not mention 
it explicitely. It might screw up someone's filters who does not want that extra 
mail notifying him that you added urself to the cc list :) cheers!

Comment 41

16 years ago
I emailed Ian last night and he responded that he was using the Change Multiple
Bugs function and was forced to add a comment before it would allow him to proceed.

Comment 42

16 years ago
This bug should be marked WONTFIX, now that there is a valid menu off of the
Print button, with Print and Print Preview.  See also bug 130066, which jives
with (the first part of) comment 5 and would add a third item to the menu.
(Reporter)

Comment 43

16 years ago
No, this bug is still valid. See comment 6. I have yet to see *any* program
(other than Mozilla) which is stupid enough to have a Print toolbar menu, no
matter how many items it has.
(Assignee)

Comment 44

15 years ago
we have 2 items now, goodbye!
Status: ASSIGNED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.