Last Comment Bug 630444 - Trim LSP annotations
: Trim LSP annotations
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Networking (show other bugs)
: unspecified
: x86 All
: -- normal (vote)
: ---
Assigned To: Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
:
:
Mentors:
Depends on:
Blocks: 626994
  Show dependency treegraph
 
Reported: 2011-01-31 20:11 PST by Jeff Muizelaar [:jrmuizel]
Modified: 2011-04-13 19:56 PDT (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Trim lsp annotation (1.43 KB, patch)
2011-01-31 20:11 PST, Jeff Muizelaar [:jrmuizel]
no flags Details | Diff | Splinter Review
Patch (615 bytes, patch)
2011-01-31 21:25 PST, Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary)
ted: review+
dtownsend: approval2.0+
Details | Diff | Splinter Review

Description Jeff Muizelaar [:jrmuizel] 2011-01-31 20:11:38 PST
Created attachment 508657 [details] [diff] [review]
Trim lsp annotation

The LSP annotation code is taking up a large chunk of the AppNotes space, which I'd like to use for other purposes. This should trim it down a bit.
Comment 1 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-01-31 20:17:31 PST
How about we just remove it from the appnotes entirely?  It gets cut off before anything interesting anyways :-/
Comment 2 Jeff Muizelaar [:jrmuizel] 2011-01-31 21:22:59 PST
(In reply to comment #1)
> How about we just remove it from the appnotes entirely?  It gets cut off before
> anything interesting anyways :-/

That works for me too. Do you want to take it out then?
Comment 3 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-01-31 21:23:41 PST
Sure.
Comment 4 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-01-31 21:25:36 PST
Created attachment 508669 [details] [diff] [review]
Patch

Ted, want to rubberstamp this?
Comment 5 Josh Matthews [:jdm] 2011-02-01 00:09:24 PST
Well, it _is_ a very easy way to notice that a non-English version of Windows is being used.
Comment 6 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-02-01 03:25:09 PST
If that information is particularly useful we could expose it in a much less voluminous manner.
Comment 7 Christian :Biesinger (don't email me, ping me on IRC) 2011-02-01 14:58:16 PST
Why not remove the note variable as well?
Comment 8 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-02-01 15:07:03 PST
Yeah, I'll kill that when I land this.
Comment 9 Jeff Muizelaar [:jrmuizel] 2011-02-01 18:57:17 PST
I landed the reviewed version:
http://hg.mozilla.org/mozilla-central/rev/c698ef73edae

You can fix the dead code in a follow up.
Comment 10 Kyle Huey [:khuey] (Exited; not receiving bugmail, email if necessary) 2011-04-13 19:56:56 PDT
http://hg.mozilla.org/mozilla-central/rev/347c9f93d23b

And the dead code is gone.

Note You need to log in before you can comment on or make changes to this bug.