If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Seamonkey doesn´t open vcf-files properly

NEW
Unassigned

Status

()

Firefox
File Handling
7 years ago
a year ago

People

(Reporter: albert.roeder, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.16) Gecko/20101123 SeaMonkey/2.0.11

If we want to open a vcf-file with seamonkey to save it in the addressbook, there are two differnet things that happen:
On some pcs in our network the vcf-file is opened in the browser in plain text instead of the mask of the addressbook.
On other pcs there opens a browserwindow and a small window in which the user is asked with which programm the file should be opened. If the user enters "Seamonkey" and presses "OK" then another browserwindow and small window open in which the user is asked with which programm the file should be opened. And so on ...

We have also visited a website with included vcf-files using seamonkey as the browser. Clicking on the link of the vcf-file opens the file correctly showing the details in the mask of the addressbook. Saving the same vcf-file on harddisk and opening it from there shows the details in a browserwindow in plain text.
When we visit the same website mentioned above with another browser (firefox, IE) even clicking on the link shows the vcf-file in plain text.

Reproducible: Always

Steps to Reproduce:
1. Open a vcf-file from harddiskdrive
2.
3.
Actual Results:  
The file was opened in a browserwindow in plain text

Expected Results:  
It should have opened the file in the mask of the addressbook so I could have selected the addressbook in which the contact should be saved.

All our pcs run with Windows XP SP3, most use Seamonkey 2.0.11, some Seamonkey 2.0.10
(Reporter)

Updated

7 years ago
Version: unspecified → SeaMonkey 2.0 Branch
This is a content-type issue. We should probably teach the unknown content-decoder about .vcf files.

Mark: Do you know which content-type the address book accepts ?
text/directory or text/x-vcard ?
(Reporter)

Comment 2

7 years ago
Just wanted to ask whether there are further informations concerning this problem.
Many thx
Albert
Reporter:
Is there a content-type specified in your windows registry for .vcf ?
In my win7 registry i have "Content Type text/x-vcard" and a drag&drop of the file to Seamonkey works as expected.
(Reporter)

Comment 4

7 years ago
Hallo!
We are working on Windows XP SP3. There was no content-type specified in the registry so I added a key for .vcf.
But it still doesn´t work - the vcard is shown in plain text and not in the mask of seamonkey.
Is there a .vcf entry in the mimetypes.rdf file that is located on your Seamonkey profile folder ?
(Reporter)

Comment 6

7 years ago
No, there is no entry for .vcf files in the mimetypes.rdf file. How can I include it?
The registry entry should work and it might fail if you have a wrong entry in mimetypes.rdf.

This is the problem:
The web and email doesn't know anything about file extensions. All web-servers provide a mime-type in the http headers and all email attachments include a mime-type in the email itself. Local files or FTP sources are without mimetypes and in that case the internal unknown content-decoder is used
The mapping mimetypes -> File extension is done with internal list -> mimetypes.rdf -> windows registry

The solution is here to add the mimetype to our internal list.
I will try to add a short patch later that will do that.

As workaround try this :
open http://mversen.de/mozilla/rar/test.vcf and select save and remember this..
No go to edit\preferences\browser\helper applications\ and change .vcf back to "always ask". This should generate in info in mimetypes.rdf
(Reporter)

Comment 8

7 years ago
Now the vcf opens in the mask. Many thanks for that.
But there is one more - hopefully little - problem: words with a special character of the german language (ö, ä, ü and so on) are shown cryptically.
My name Röder is once shown as R with two more signs with no meaning (that can´t be copied and pasted in any way) and anothertime as R=F6der (in the same vcf-file). Our country (Österreich) only consists of cryptically signs.
I don´t know whether the problem is with the vcf-file or with the settings of our seamonkey. Can I change the settings for this problem in seamonkey?
Thank you very much!!
I don't know the answer but that is another bug. Note: Bugzilla is not the support. Write a new bug in Mailnews Core: Adressbook
(Reporter)

Comment 10

7 years ago
Thank you very much!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
no, not fixed because I can't see a patch here that "fixed" it in the product.
Status: RESOLVED → UNCONFIRMED
Component: General → File Handling
Product: SeaMonkey → Core
QA Contact: general → file-handling
Resolution: FIXED → ---
Version: SeaMonkey 2.0 Branch → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

a year ago
Component: File Handling → File Handling
Product: Core → Firefox
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.