Extra resize grip in addon toolbar in 20110201 nightly

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
8 years ago
8 years ago

People

(Reporter: after.fallout, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre
Build Identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

This morning after opening firefox I noticed that Firebug had moved over a little bit. Looking closer I noticed that there is an extra resize grip, right next to the regular one.

Reproducible: Always

Steps to Reproduce:
1. Open browser
2. Notice extra grip in addon bar
(Reporter)

Comment 1

8 years ago
Created attachment 508749 [details]
Screenshots taken in normal and customize toolbars mode

Took a screenshot of this portion of my window. When in customize toolbar mode, the grips are in different backgrounds, one in the area where addons add buttons and the other not.

Comment 2

8 years ago
Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre

Works for me. Please try if it works fine in safe mode or try by creating a new profile. 
https://support.mozilla.com/en-US/kb/Safe+Mode
https://support.mozilla.com/en-US/kb/Managing+profiles#Creating_a_profile.
(Reporter)

Comment 3

8 years ago
Created attachment 508773 [details]
new profile, added adblock plus

After starting a new profile, the addon bar was gone and there was only one grip. I added adblock plus and when the browser restarted I received this situation (different than the one initially reported, now the grip is on the left and above the addon button, before it was twice on the right.

After closing and opening firefox the grip on top went away, but the one on the left remains as the only grip (btw, these grips all work like they should as if they were in the bottom right corner of the browser).

Safe mode from this new profile appears fine, but the addon bar is gone. Deleting this profile and restarting with the old one and the initial problem is still there.
(Reporter)

Comment 4

8 years ago
Safe mode from the original profile works as well, but again the addon bar is not there at all.
In non-maximized Mode I see one visible Resizer, but if you hover over the Edge from the bottom right to the top left you can see that there's also one hidden Resizer.

Maximized Mode is WFM.

Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre ID:20110201030339
Bill, in safe mode can you enable the addon bar and then see is you get too resizers? I'm wondering if this is caused by adblock.
Go into Safe mode, hit Alt, then go View, toolbars, addon bar.
(Reporter)

Comment 7

8 years ago
Testing now in today's nightly: Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

In safe mode I do not get a second visible resizer. Even if I enable the addon toolbar.

Creating a new profile and adding firebug does not cause the issue. Adding ABP causes a single grip to be on the left side of ABP (should be on right side). The grip above does not appear today.

Default profile still has two grips.

--
All troubleshooting info to help someone reproduce:


  Application Basics

        Name
        Firefox

        Version
        4.0b11pre

        User Agent
        Mozilla/5.0 (Windows NT 5.1; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

        Profile Directory

          Open Containing Folder

        Enabled Plugins

          about:plugins

        Build Configuration

          about:buildconfig

  Extensions

        Name

        Version

        Enabled

        ID

        Microsoft .NET Framework Assistant
        1.2.1
        false
        {20a82645-c095-46ed-80e3-08825760534b}

        Download Statusbar
        0.9.7.2
        true
        {D4DD63FA-01E4-46a7-B6B1-EDAB7D6AD389}

        Add-on Compatibility Reporter
        0.7
        true
        compatibility@addons.mozilla.org

        Selenium IDE: Ruby Formatters
        1.0.0
        false
        rubyformatters@seleniumhq.org

        Selenium IDE: C# Formatters
        1.0.0
        true
        csharpformatters@seleniumhq.org

        Selenium IDE: Groovy Formatters
        1.0.0
        true
        groovyformatters@seleniumhq.org

        Selenium IDE: Java Formatters
        1.0.0
        true
        javaformatters@seleniumhq.org

        Selenium IDE: Perl Formatter
        1.0.0
        true
        perlformatters@seleniumhq.org

        Selenium IDE: PHP Formatters
        1.0.0
        true
        phpformatters@seleniumhq.org

        Selenium IDE: Python Formatters
        1.0.0
        true
        pythonformatters@seleniumhq.org

        Firebug
        1.7X.0a9
        true
        firebug@software.joehewitt.com

        Java Quick Starter
        1.0
        true
        jqs@sun.com

        Status-4-Evar
        2011.01.17.02
        true
        status4evar@caligonstudios.com

        Greasemonkey
        0.9.1
        false
        {e4a8a97b-f2ed-450b-b12d-ee082ba24781}

        Java Console
        6.0.13
        true
        {CAFEEFAC-0016-0000-0013-ABCDEFFEDCBA}

        Java Console
        6.0.14
        true
        {CAFEEFAC-0016-0000-0014-ABCDEFFEDCBA}

        Java Console
        6.0.15
        true
        {CAFEEFAC-0016-0000-0015-ABCDEFFEDCBA}

        Java Console
        6.0.17
        true
        {CAFEEFAC-0016-0000-0017-ABCDEFFEDCBA}

        Java Console
        6.0.20
        true
        {CAFEEFAC-0016-0000-0020-ABCDEFFEDCBA}

        Selenium IDE
        1.0.10
        false
        {a6fd85ed-e919-4a43-a5af-8da18bda539f}

        Adblock Plus
        1.3.3
        true
        {d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}

  Modified Preferences

      Name

      Value

        accessibility.typeaheadfind.flashBar
        0

        browser.places.importBookmarksHTML
        false

        browser.places.smartBookmarksVersion
        2

        browser.startup.homepage_override.buildID
        20110202030356

        browser.startup.homepage_override.mstone
        rv:2.0b11pre

        extensions.checkCompatibility
        false

        extensions.checkCompatibility.3.6
        false

        extensions.checkCompatibility.3.6b
        false

        extensions.checkCompatibility.3.6p
        false

        extensions.checkCompatibility.3.6pre
        false

        extensions.checkCompatibility.3.7a
        false

        extensions.checkCompatibility.4.0b
        false

        extensions.checkCompatibility.4.0p
        false

        extensions.checkCompatibility.4.0pre
        false

        extensions.lastAppVersion
        4.0b11pre

        general.useragent.extra.microsoftdotnet
        ( .NET CLR 3.5.30729; .NET4.0E)

        gfx.font_rendering.directwrite.enabled
        true

        network.cookie.prefsMigrated
        true

        places.database.lastMaintenance
        1296572290

        places.history.expiration.transient_current_max_pages
        64121

        places.last_vacuum
        1282075947

        privacy.sanitize.migrateFx3Prefs
        true

        security.warn_viewing_mixed
        false

  Graphics

        Adapter Description
        Mobile Intel(R) 945GM Express Chipset Family

        Vendor ID
        8086

        Device ID
        27a2

        Adapter RAM
        Unknown

        Adapter Drivers
        ialmrnt5

        Driver Version
        6.14.10.4446

        Driver Date
        12-13-2005

        Direct2D Enabled
        false

        DirectWrite Enabled
        true (0.0.0.0, font cache n/a)

        WebGL Renderer
        (WebGL unavailable)

        GPU Accelerated Windows
        0/1

Updated

8 years ago
Version: unspecified → Trunk
(Reporter)

Comment 8

8 years ago
The extra grip is now gone as of Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110204 Firefox/4.0b12pre

Should this bug be wfm, invalid or fixed, or is there something to dupe it to?
We'll WFM it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.