Window state is lost after minimizing

RESOLVED FIXED in mozilla0.8

Status

()

Core
XUL
RESOLVED FIXED
17 years ago
17 years ago

People

(Reporter: Blake Ross, Assigned: Dan M)

Tracking

Trunk
mozilla0.8
x86
Windows ME
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Build ID: 12/16 trunk (tip)

Steps to Reproduce:

(1) Open an instance of Navigator.
(2) Maximize it (using the maximize button in the top right of the titlebar).
(3) Minimize it (using the minimize button in the top right of the titelbar).
(4) Maximize it (click on its placeholder in the taskbar).

Result: the window maximizes then quickly restores. see bug 32148.

Comment 1

17 years ago
Hmmm. This is caused by the combination of two problems:

1. NS_SIZEMODE event is spawsned in WM_SYSCOMMAND.
   This is already bad see my comments in bug 63052
   When restoring a minimized window we get "SC_RESTORE" from which the code
   badly assumes we just entered the "Normal" state...

2. The handler of the NS_SIZEMODE handler in
   "xpfe/appshell/src/nsWebShellWindow.cpp" is calling SetSizeMode which
   sets the the window state by calling ShowWindow.
   This is bad(tm). An event handler that is notified about a mode change,
   shouldn't change the mode itself. It has the potential to create an endless
   flow of events.

Comment 2

17 years ago
Confirmed in 2000121608 under win98 SE
(Reporter)

Comment 3

17 years ago
Marking fixed per Péter's 12/18 comment in bug 63052 that his patch fixes this 
also.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
(Assignee)

Updated

17 years ago
Target Milestone: --- → mozilla0.8
You need to log in before you can comment on or make changes to this bug.