Closed Bug 630595 Opened 9 years ago Closed 9 years ago

[Nexus S] 2011-02-01 builds are crashy and runs out of memory

Categories

(Firefox for Android Graveyard :: General, defect, critical)

ARM
Android
defect
Not set
critical

Tracking

(fennec2.0b5+)

VERIFIED FIXED
Tracking Status
fennec 2.0b5+ ---

People

(Reporter: tchung, Assigned: dougt)

References

()

Details

Attachments

(3 files)

Creating a new bug here, but its really all related to bug 624652, bug 630080

The 2/1 nightly builds are repeatedly content crashing on the Nexus S.   The logs all point to oom errors.  Visiting any site will trigger the crash.  Planet.mozilla.org is always a reproducible scenario.  Once you've dismissed the restart tab dialog, it's pretty much crash on any execution afterwards.

Screenshot and log attached

Repro:
1) On Nexus S, install fennec android nightly: Mozilla/5.0 (Android; Linux armv71; rv:2.0b11pre) Gecko/20110201 Firefox/4.0b11pre Fennec/4.0b5pre
2) launch fennec with minimal apps open
3) visit URL
4) Verify content process crash, and logcat outputs oom errors:

Expected:
- page loads, no crashes

Actual:
- oom, content crash.  recoverable, but starting up fennec will crash pretty much instantly
Attached file adb crash log
cc'ing others that have a Nexus S
Assignee: nobody → doug.turner
tracking-fennec: ? → 2.0b5+
I can confirm this. Any idea what made us regress here? Previous nightly was running just fine...
Summary: [Nexus S] 2/1 builds are crashy and runs out of memory → [Nexus S] 2011-02-01 builds are crashy and runs out of memory
philipp, previous nightlies would have killed your phone requiring you to pull the battery out.  see bug 624652.

would you mind trying http://people.mozilla.org/~dougt/fennec.apk
(In reply to comment #4)
> would you mind trying http://people.mozilla.org/~dougt/fennec.apk

I tried to install this, but then it just says "Application not installed." What am I doing wrong?
you need to uninstall the nightly, and then reinstall this build.  The reason is that my key isn't the same key that the nightlies use.
(In reply to comment #6)
> you need to uninstall the nightly, and then reinstall this build.  The reason
> is that my key isn't the same key that the nightlies use.

Gotcha. That worked. This build works just fine, though I cannot make any statements about whether bug 624652 was really fixed or not. I have seen the phone freeze up twice since I got it on Saturday, but I don't remember whether that was Fennec related or not.
Actually the content process just crashed with just two tabs open, one was the welcome page, the other was a random bugzilla page I opened from history. This was during the initial sync.
Attached patch patch v.1Splinter Review
brad, i will backout the memory watcher when this is checked in.
Attachment #509038 - Flags: review?(blassey.bugs)
Attachment #509038 - Flags: review?(blassey.bugs) → review+
Sync just completed, still getting occasional content process crashes if I open memory-intensive pages (tbpl, techcrunch -- lots of Like buttons --, etc.)
http://hg.mozilla.org/mozilla-central/rev/1bbbe11e2968
http://hg.mozilla.org/mozilla-central/rev/99af9d6485bb
http://hg.mozilla.org/mozilla-central/rev/9dad67994e82

Setting expectations here -- you can still run out of memory, and the content process can still crash for both oom and for other crash badness.  The device has a fixed amount of memory, and no swap.

What I landed above, will free us from device freezes (bug 624652), and I will allow you to run without any memory watching timers (bug 629432).
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Verified the Feb 2nd builds arent as crashy on startup as it was before.   however, bug 630955 is newly filed and will be commenting my experience in that bug.
Status: RESOLVED → VERIFIED
backed out the fix that failed to fix.

http://hg.mozilla.org/mozilla-central/rev/e2290c8b6d36

lets just leave this closed and work in 630955...
You need to log in before you can comment on or make changes to this bug.