Crash when clicking on date/time in the left column on tinderbox

VERIFIED FIXED

Status

()

Core
DOM: Core & HTML
--
critical
VERIFIED FIXED
17 years ago
17 years ago

People

(Reporter: Phil "clef" Sweeney, Assigned: jst)

Tracking

({crash})

Trunk
x86
All
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
BuildID: 2000121608 (also crashes on nightlies from day before this)

Steps to reproduce:

1. Click 'tinderbox' on personal toolbar (or go to url listed in this bug)
2. Scroll down and choose a date/time from the left column
3. Click back
4. Go to Step 2 and choose a different date/time

Doing this once or twice crashes everytime for me.  Can also do it by choosing 
'back 24 hours' and choosing a date/time etc.  Seems to need about 3-4 page 
transitions from launch to happen.  Crash was also confirmed by Styx on 
n.p.m.builds.

Comment 1

17 years ago
Crashed twice with linux SEA 2000121521 while testing this.
-First time after hitting back-button.
-Second time after clicking link (back-button ok then.)

The last crash was in or around FinalizeHTMLBodyElement from libmozjs.so, and
i've had many crashes showing that today.

Attaching half useless backtrace from non-debug build.
Resolving as new, OS: All.

Comment 2

17 years ago
new - all.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All

Comment 3

17 years ago
Created attachment 20819 [details]
2 non-debug bt's

Comment 4

17 years ago
spammers-R-me..
Adding kw.
Keywords: crash

Updated

17 years ago
Assignee: asa → jst
Component: Browser-General → DOM Level 0
QA Contact: doronr → desale

Comment 5

17 years ago
unable to repro with 121808 mozilla build on redhat6.2  over to DOM for triage.
(Reporter)

Comment 6

17 years ago
I can no longer reproduce this either.  I'll try it again tomorrow and mark it 
fixed if it still does not occur.
(Assignee)

Comment 7

17 years ago
This was due to a refcounting mistake I made in one of my checkins last week, I
fixed the problem last weekend. ==> FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Verified with 2001-02-06-08-Mtrunk on Linux.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.