Flash crash [@ gfxASurface::GetType() ] getting surface type

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: jimm, Assigned: benjamin)

Tracking

({regression, topcrash})

Trunk
x86
Windows 7
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking2.0 final+)

Details

(Whiteboard: [hardblocker] probably fixed by 626602, need to check crash-stats, crash signature)

0 	xul.dll 	gfxASurface::GetType 	gfx/thebes/gfxASurface.cpp:233
1 	xul.dll 	mozilla::gfx::SharedDIBSurface::IsSharedDIBSurface 	gfx/ipc/SharedDIBSurface.cpp:93
2 	xul.dll 	mozilla::plugins::PluginInstanceChild::ReadbackDifferenceRect 	dom/plugins/PluginInstanceChild.cpp:2886
3 	xul.dll 	mozilla::plugins::PluginInstanceChild::ShowPluginFrame 	dom/plugins/PluginInstanceChild.cpp:2812
4 	xul.dll 	mozilla::plugins::PluginInstanceChild::InvalidateRectDelayed 	dom/plugins/PluginInstanceChild.cpp:2924
5 	xul.dll 	MessageLoop::RunTask 	ipc/chromium/src/base/message_loop.cc:343
6 	xul.dll 	MessageLoop::DeferOrRunPendingTask 	ipc/chromium/src/base/message_loop.cc:351
7 	xul.dll 	MessageLoop::DoWork 	ipc/chromium/src/base/message_loop.cc:451
8 	xul.dll 	base::MessagePumpForUI::DoRunLoop 	ipc/chromium/src/base/message_pump_win.cc:213
9 	xul.dll 	base::MessagePumpWin::RunWithDispatcher 	ipc/chromium/src/base/message_pump_win.cc:52
10 	xul.dll 	base::MessagePumpWin::Run 	ipc/chromium/src/base/message_pump_win.h:78
11 	xul.dll 	MessageLoop::RunInternal 	ipc/chromium/src/base/message_loop.cc:219


#9 top crasher in beta 10. Checking for a valid shared DIB surface. Appears unrelated to anything flash is doing.
I'll bet that mBackSurface is null here. I can't guess why, yet. http://hg.mozilla.org/mozilla-central/annotate/FIREFOX_4_0b10_RELEASE/dom/plugins/PluginInstanceChild.cpp#l2886
Assignee: nobody → benjamin
blocking2.0: ? → final+
Keywords: regression, topcrash
This could probably block on bug 626602 since this code is about to get another overhaul.
Whiteboard: [hardblocker]
Depends on: 626602
Whiteboard: [hardblocker] → [hardblocker] waiting on bug 606602 to land.
626602 landed, what's the prognosis for a fix here?
We need to check crash-stats for next-beta, I believe that bug 626602 will just make this go away.
Whiteboard: [hardblocker] waiting on bug 606602 to land. → [hardblocker] probably fixed by 626602, need to check crash-stats
Not a single crash that matches this in the 20110216030352 build. Looks fixed to me.
concur!
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Crash Signature: [@ gfxASurface::GetType() ]
You need to log in before you can comment on or make changes to this bug.