crash [@ nsCoreUtils::IsColumnHidden(nsITreeColumn*) | nsXULTreeItemAccessibleBase::IsExpandable]

RESOLVED DUPLICATE of bug 573934

Status

()

Core
Disability Access APIs
--
critical
RESOLVED DUPLICATE of bug 573934
8 years ago
7 years ago

People

(Reporter: timeless, Unassigned)

Tracking

({crash})

1.9.2 Branch
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

8 years ago
This bug was filed from the Socorro interface and is 
report bp-1fed9e6f-4041-4eb3-9152-b8ca62110111 .
============================================================= 
Signature	nsCoreUtils::IsColumnHidden(nsITreeColumn*)
UUID	1fed9e6f-4041-4eb3-9152-b8ca62110111
Time 	2011-01-11 15:14:49.20248
Uptime	27867
Last Crash	6456254 seconds (10.7 weeks) before submission
Install Age	2739404 seconds (4.5 weeks) since version was first installed.
Product	Thunderbird
Version	3.1.7
Build ID	20101207084811
Branch	1.9.2
OS	Linux
OS Version	0.0.0 Linux 2.6.34.7-0.7-desktop #1 SMP PREEMPT 2010-12-13 11:13:53 +0100 x86_64
CPU	x86
CPU Info	AuthenticAMD family 16 model 5 stepping 2
Crash Reason	SIGSEGV
Crash Address	0x0
User Comments	
Processor Notes 	
EMCheckCompatibility	False
Bugzilla - Report this Crash
Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	thunderbird-bin 	nsCoreUtils::IsColumnHidden 	accessible/src/base/nsCoreUtils.cpp:1105
1 	thunderbird-bin 	nsXULTreeItemAccessibleBase::IsExpandable 	accessible/src/xul/nsXULTreeAccessible.cpp:1210
2 	thunderbird-bin 	nsXULTreeItemAccessibleBase::GetNumActions 	accessible/src/xul/nsXULTreeAccessible.cpp:987
3 	thunderbird-bin 	nsAccessibleWrap::CreateMaiInterfaces 	accessible/src/atk/nsAccessibleWrap.cpp:408
4 	thunderbird-bin 	nsAccessibleWrap::GetNativeInterface 	accessible/src/atk/nsAccessibleWrap.cpp:361
5 	thunderbird-bin 	nsAccessibleWrap::GetAtkObject 	accessible/src/atk/nsAccessibleWrap.cpp:391
6 	thunderbird-bin 	nsAccessibleWrap::FirePlatformEvent 	accessible/src/atk/nsAccessibleWrap.cpp:1129
7 	thunderbird-bin 	nsAccUtils::FireAccEvent 	accessible/src/base/nsAccUtils.cpp:354
8 	thunderbird-bin 	nsRootAccessible::HandleEventWithTarget 	accessible/src/base/nsRootAccessible.cpp:767
9 	thunderbird-bin 	nsRootAccessible::HandleEvent 	accessible/src/base/nsRootAccessible.cpp:597
10 	thunderbird-bin 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1041
11 	thunderbird-bin 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1147
12 	thunderbird-bin 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:246
13 	thunderbird-bin 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:281
14 	thunderbird-bin 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:573
15 	thunderbird-bin 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:636
16 	thunderbird-bin 	nsEventListenerManager::DispatchEvent 	content/events/src/nsEventListenerManager.cpp:1274
17 	thunderbird-bin 	nsDOMEventRTTearoff::DispatchEvent 	content/base/src/nsGenericElement.cpp:1672
18 	thunderbird-bin 	nsContentUtils::DispatchTrustedEvent 	content/base/src/nsContentUtils.cpp:3229
19 	thunderbird-bin 	nsPLDOMEvent::Run 	content/events/src/nsPLDOMEvent.cpp:65
20 	thunderbird-bin 	nsContentUtils::AddScriptRunner 	content/base/src/nsContentUtils.cpp:4524
21 	thunderbird-bin 	nsPLDOMEvent::RunDOMEventWhenSafe 	content/events/src/nsPLDOMEvent.cpp:80
22 	thunderbird-bin 	nsTreeSelection::FireOnSelectHandler 	layout/xul/base/src/tree/src/nsTreeSelection.cpp:852
23 	thunderbird-bin 	nsTreeSelection::SetSelectEventsSuppressed 	layout/xul/base/src/tree/src/nsTreeSelection.cpp:621
24 	thunderbird-bin 	nsMsgDBView::RestoreSelection 	mailnews/base/src/nsMsgDBView.cpp:868
25 	thunderbird-bin 	nsMsgThreadedDBView::Sort 	mailnews/base/src/nsMsgThreadedDBView.cpp:396
26 	libxpcom_core.so 	libxpcom_core.so@0x6876e 	
27 	thunderbird-bin 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:2722
28 	thunderbird-bin 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1740
29 	libmozjs.so 	js_Invoke 	js/src/jsinterp.cpp:1360
30 	libmozjs.so 	js_Interpret 	js/src/jsops.cpp:2240
31 	libmozjs.so 	js_Invoke 	js/src/jsinterp.cpp:1368
32 	libmozjs.so 	js_InternalInvoke 	js/src/jsinterp.cpp:1423
33 	libmozjs.so 	js_InternalGetOrSet 	js/src/jsinterp.cpp:1486
34 	libmozjs.so 	js_SetSprop 	js/src/jsscope.h:625
35 	libmozjs.so 	js_SetPropertyHelper 	js/src/jsobj.cpp:4458
36 	libmozjs.so 	js_Interpret 	js/src/jsops.cpp:1854
37 	libmozjs.so 	js_Invoke 	js/src/jsinterp.cpp:1368
38 	libmozjs.so 	js_InternalInvoke 	js/src/jsinterp.cpp:1423
39 	libmozjs.so 	js_InternalGetOrSet 	js/src/jsinterp.cpp:1486
40 	libmozjs.so 	js_SetSprop 	js/src/jsscope.h:625
41 	libmozjs.so 	js_SetPropertyHelper 	js/src/jsobj.cpp:4458
42 	libmozjs.so 	js_Interpret 	js/src/jsops.cpp:1854
43 	libmozjs.so 	js_Invoke 	js/src/jsinterp.cpp:1368
44 	libmozjs.so 	js_InternalInvoke 	js/src/jsinterp.cpp:1423
45 	libmozjs.so 	JS_CallFunctionValue 	js/src/jsapi.cpp:5114
46 	thunderbird-bin 	nsJSContext::CallEventHandler 	dom/base/nsJSEnvironment.cpp:2197
47 	thunderbird-bin 	nsJSEventListener::HandleEvent 	dom/src/events/nsJSEventListener.cpp:269
48 	thunderbird-bin 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1041
49 	thunderbird-bin 	nsEventListenerManager::HandleEvent 	content/events/src/nsEventListenerManager.cpp:1147
50 	thunderbird-bin 	nsEventTargetChainItem::HandleEvent 	content/events/src/nsEventDispatcher.cpp:246
51 	thunderbird-bin 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventDispatcher.cpp:310
52 	thunderbird-bin 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:573
53 	thunderbird-bin 	nsEventDispatcher::DispatchDOMEvent 	content/events/src/nsEventDispatcher.cpp:636
54 	thunderbird-bin 	PresShell::HandleDOMEventWithTarget 	layout/base/nsPresShell.cpp:6590
55 	thunderbird-bin 	nsContentUtils::DispatchXULCommand 	content/base/src/nsContentUtils.cpp:5142
56 	thunderbird-bin 	nsXULMenuCommandEvent::Run 	layout/xul/base/src/nsXULPopupManager.cpp:2120
57 	libxpcom_core.so 	nsThread::ProcessNextEvent 	xpcom/threads/nsThread.cpp:527

1197 nsXULTreeItemAccessibleBase::IsExpandable()

1209 columns->GetPrimaryColumn(getter_AddRefs(primaryColumn));

primaryColumn can be null, and is, and the callee expects callers not to pass null
1210 if (!nsCoreUtils::IsColumnHidden(primaryColumn))
(Reporter)

Updated

8 years ago
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 573934
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsCoreUtils::IsColumnHidden(nsITreeColumn*) | nsXULTreeItemAccessibleBase::IsExpandable]
You need to log in before you can comment on or make changes to this bug.