Closed Bug 630780 Opened 9 years ago Closed 6 years ago

Intermittent OS X mochitest TEST-UNEXPECTED-FAIL | Shutdown | Exited with code -20 during test run

Categories

(Core :: General, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: ehsan, Unassigned)

References

Details

(Keywords: crash, intermittent-failure)

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296617355.1296618221.3781.gz&fulltext=1
Rev3 MacOSX Snow Leopard 10.6.2 mozilla-central debug test mochitests-5/5 on 2011/02/01 19:29:15

NOTE: child process received `Goodbye', closing down
WARNING: NS_ENSURE_TRUE(compMgr) failed: file nsComponentManagerUtils.cpp, line 81
nsStringStats
 => mAllocCount:             70
 => mReallocCount:            0
 => mFreeCount:              70
 => mShareCount:            113
 => mAdoptCount:              0
 => mAdoptFreeCount:          0
TEST-UNEXPECTED-FAIL | Shutdown | Exited with code -20 during test run
INFO | automation.py | Application ran for: 0:11:44.161260
INFO | automation.py | Reading PID log: /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpZUvyIMpidlog
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, plugin process 313

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          40        0      224        0 (   24.30 +/-    18.41)      206        0 (   51.28 +/-    37.47)

nsTraceRefcntImpl::DumpStatistics: 14 entries
TEST-PASS | plugin process 313 | automationutils.processLeakLog() | no leaks detected!

INFO | runtests.py | Running tests: end.
program finished with exit code 236
elapsedTime=709.016304
TinderboxPrint: mochitest-plain-5<br/>19576/0/27&nbsp;<em class="testfail">L-FAIL</em>
Unknown Error: command finished with exit code: 236
http://tinderbox.mozilla.org/showlog.cgi?log=Mozilla-Aurora/1305579302.1305580587.29175.gz

20055 INFO TEST-END | /tests/uriloader/exthandler/tests/mochitest/test_unsafeBidiChars.xhtml | finished in 14835ms
20056 INFO TEST-START | Shutdown
20057 INFO Passed: 19586
20058 INFO Failed: 0
20059 INFO Todo:   27
20060 INFO SimpleTest FINISHED
++DOMWINDOW == 16 (0x12b164da8) [serial = 1005] [outer = 0x11acf9f00]
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x120f4e520 == 6
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x120f66280 == 5
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_SUCCESS(rv, 0) failed with result 0x8000FFFF: file /builds/slave/aurora-osx64-dbg/build/content/base/src/nsContentUtils.cpp, line 2917
WARNING: NS_ENSURE_TRUE(pusher.Push(aBoundElement)) failed: file /builds/slave/aurora-osx64-dbg/build/content/xbl/src/nsXBLProtoImplMethod.cpp, line 327
--DOCSHELL 0x10394ab80 == 4
--DOMWINDOW == 15 (0x1222975f8) [serial = 12] [outer = 0x1220d9400] [url = http://mochi.test:8888/tests/?autorun=1&closeWhenDone=1&consoleLevel=INFO&totalChunks=5&thisChunk=5&chunkByDir=4]
--DOMWINDOW == 14 (0x12b1e49a8) [serial = 1004] [outer = 0x12e11dff0] [url = about:blank]
--DOCSHELL 0x103970b80 == 3
== GLContext 0x121809000 ==
Outstanding Textures:

Outstanding Buffers:

Outstanding Programs:

Outstanding Shaders:

Outstanding Framebuffers:

Outstanding Renderbuffers:

--DOCSHELL 0x1220d7c80 == 2
--DOCSHELL 0x11acf8670 == 1
--DOMWINDOW == 13 (0x1220d9478) [serial = 7] [outer = 0x0] [url = http://mochi.test:8888/tests/?autorun=1&closeWhenDone=1&consoleLevel=INFO&totalChunks=5&thisChunk=5&chunkByDir=4]
--DOMWINDOW == 12 (0x12e11e068) [serial = 1003] [outer = 0x0] [url = about:blank]
--DOCSHELL 0x12e01bde0 == 0
--DOMWINDOW == 11 (0x122183d48) [serial = 9] [outer = 0x120f4fb00] [url = about:blank]
--DOMWINDOW == 10 (0x120f4fb78) [serial = 5] [outer = 0x0] [url = about:blank]
--DOMWINDOW == 9 (0x12218d848) [serial = 10] [outer = 0x120f66a80] [url = about:blank]
--DOMWINDOW == 8 (0x120f66af8) [serial = 6] [outer = 0x0] [url = about:blank]
NOTE: child process received `Goodbye', closing down
WARNING: NS_ENSURE_TRUE(compMgr) failed: file nsComponentManagerUtils.cpp, line 81
nsStringStats
 => mAllocCount:             74
 => mReallocCount:            1
 => mFreeCount:              74
 => mShareCount:            117
 => mAdoptCount:              0
 => mAdoptFreeCount:          0
TEST-UNEXPECTED-FAIL | Shutdown | Exited with code -20 during test run
INFO | automation.py | Application ran for: 0:13:53.162529
INFO | automation.py | Reading PID log: /var/folders/H5/H5TD8hgwEqKq9hgKlayjWU+++TM/-Tmp-/tmpM8TGMPpidlog
TEST-UNEXPECTED-FAIL | automationutils.processLeakLog() | missing output line for total leaks!

== BloatView: ALL (cumulative) LEAK AND BLOAT STATISTICS, plugin process 343

     |<----------------Class--------------->|<-----Bytes------>|<----------------Objects---------------->|<--------------References-------------->|
                                              Per-Inst   Leaked    Total      Rem      Mean       StdDev     Total      Rem      Mean       StdDev
   0 TOTAL                                          39        0      238        0 (   24.86 +/-    19.22)      215        0 (   53.38 +/-    39.04)

nsTraceRefcntImpl::DumpStatistics: 16 entries
TEST-PASS | plugin process 343 | automationutils.processLeakLog() | no leaks detected!

INFO | runtests.py | Running tests: end.
program finished with exit code 236
elapsedTime=840.827404
TinderboxPrint: mochitest-plain-5<br/>19586/0/27&nbsp;<em class="testfail">L-FAIL</em>
Unknown Error: command finished with exit code: 236
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1307741033.1307744699.26010.gz
Summary: Intermittent shutdown crash on mochitest-5 osx (Exited with code -20 during test run) → Intermittent shutdown crash on mochitest-4 or mochitest-5 osx (Exited with code -20 during test run)
Summary: Intermittent shutdown crash on mochitest-4 or mochitest-5 osx (Exited with code -20 during test run) → Intermittent shutdown crash on mochitest osx (Exited with code -20 during test run)
Whiteboard: [orange]
Keywords: crash
Duplicate of this bug: 781121
Summary: Intermittent shutdown crash on mochitest osx (Exited with code -20 during test run) → Intermittent OS X mochitest TEST-UNEXPECTED-FAIL | Shutdown | Exited with code -20 during test run
Duplicate of this bug: 879543
Depends on: 882670
Depends on: 884471
Depends on: 892958
Fixed (or worked around) by bug 884471.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.