Newly created LDAP address books don't use to use the SSL port if specified

VERIFIED FIXED in Thunderbird 3.3a3

Status

MailNews Core
LDAP Integration
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: standard8, Assigned: standard8)

Tracking

({regression})

Trunk
Thunderbird 3.3a3
regression

Firefox Tracking Flags

(blocking-thunderbird5.0 needed)

Details

Attachments

(1 attachment)

This is a regression on trunk. If I create a new LDAP address book which is intended to connect to an SSL LDAP directory, then the server URI preference is of the form:

ldaps://<servername>/<rest of url>

If I do the same in 3.1 the the preference is of the form:

ldaps://<servername>:636/<rest of url>

Both should in theory work, as 636 is the default for LDAP SSL, however there's obviously an issue when not specifying the default port.
cc'ing Shaver and Justdave as I think this may have been one of the issues they were seeing with LDAP a week or so ago.
Created attachment 509063 [details] [diff] [review]
The fix

Simple fix - if the URL is an SSL one, then use the LDAPS_PORT as default not the LDAP_PORT.
Attachment #509063 - Flags: review?(bienvenu)
blocking-thunderbird5.0: --- → needed

Comment 3

8 years ago
Comment on attachment 509063 [details] [diff] [review]
The fix

I tried clearing the port on an existing ldap address book using the properties dialog, and it silently set the port to 1, which is probably not what we want. But when I edited the uri by hand to remove the port, this code worked fine.
Attachment #509063 - Flags: review?(bienvenu) → review+
Checked in for today's nightly: http://hg.mozilla.org/comm-central/rev/574112080062
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a3
Application Build ID    20110204030014

You just made the cut before this build started ^^  :)

Verified.  My Mozilla address book works now. :)
(In reply to comment #5)
> Verified.  My Mozilla address book works now. :)

Excellent :-)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.