If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Add-on continues to upload even after canceling the update process

VERIFIED FIXED in 6.0.4

Status

addons.mozilla.org Graveyard
Developer Pages
P5
normal
VERIFIED FIXED
7 years ago
2 years ago

People

(Reporter: Sai Krishna, Assigned: gkoberger)

Tracking

unspecified
6.0.4
x86
Windows XP

Details

(Reporter)

Description

7 years ago
STR:
1.Login to https://addons.allizom.org/en-US/developers
2.Go to Edit Add-ons Listing page of any add-on
3.Goto Status & Versions page by clicking on Manage Status and Versions link in Left hand side
4.Click "Upload New Version" and click "select a file" and select any add-on file
5.After the upload process starts click Cancel
6.Now again click "Upload New Version"

Expected Result: at step 5 after clicking the Cancel, the add-on upload process should be canceled 

Actual Result: at step 5, even after clicking cancel the upload still continuous which you can see at step 6

Updated

7 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Add-on continuous to upload even after canceling the update process → Add-on continues to upload even after canceling the update process
Assignee: nobody → gkoberger
Priority: -- → P5
Target Milestone: --- → 6.0.0
Duplicate of this bug: 624992
Target Milestone: 6.0.0 → 6.0.1
Target Milestone: 6.0.1 → 6.0.2
(Assignee)

Comment 2

7 years ago
https://github.com/jbalogh/zamboni/commit/1506f0210aedbac0749ba2863316fa3683e9afa1

The fix is somewhere in there.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
I can actually still reproduce this:

http://screencast.com/t/9NmVpImHR
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 4

7 years ago
Good catch.  I changed the event name one place, but not the other.

http://github.com/jbalogh/zamboni/commit/5ae1ddb
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
(Assignee)

Updated

7 years ago
Whiteboard: [pickme]
The feedback isn't immediate (besides the Cancel link disappearing), and the add-on appears to keep uploading, actually (since it continues with its progress meter, and eventually gets to the validator, which appears to propagate the failure reason.  Either here or in a new bug (your choice), I'd like to see it stop all activity, or at least give more immediate feedback to the user (and cancel progress indicators, etc.)

http://screencast.com/t/8bQJwzuO5h is a screencast of current behavior.
(Assignee)

Comment 6

7 years ago
I was going to do this separately (for all errors), but since you mentioned it, here we go:

http://github.com/jbalogh/zamboni/commit/1d300c7

Comment 7

7 years ago
STR:
1. Load the /versions page for an add-on
2. Upload a new version (pick an add-on which takes a while to validate (easier to spot the bug)
3. While the add-on is being validated, click 'cancel'
4. Click on 'upload a new version' again.

observed behavior:
upload continue even after the cancellation.

reopening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 8

7 years ago
I fixed the wrong bug.  There are two cancel buttons on this page, and I thought it was referring to the small one right under the progress bar.

So, I found a bug by misinterpreting the original one :)
Let's get this in for freeze today
Whiteboard: [pickme]
Target Milestone: 6.0.2 → 6.0.3
Target Milestone: 6.0.3 → 6.0.4
(Assignee)

Comment 10

7 years ago
http://github.com/jbalogh/zamboni/commit/600b426
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED

Comment 11

7 years ago
verified fixed @ https://addons.allizom.org/en-US/developers/addon/blahblah123/versions/
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.