Mozilla will not open with some identities

VERIFIED WORKSFORME

Status

Core Graveyard
Profile: Migration
--
blocker
VERIFIED WORKSFORME
17 years ago
2 years ago

People

(Reporter: Duncan Findlay, Assigned: dbragg)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows 98)
BuildID:    2000121808

When I try to open my identity at the identity screen, Mozilla does not open.  
It remains in the end task screen (Ctrl-Alt-Del).  When I end Mozilla 
forcefully through the end task menu, I get an illegal operation.

Reproducible: Always
Steps to Reproduce:
1. Open Mozilla
2. Choose identity "duncf" (Identity created in Netscape 3, transfered to 4... 
I think), and click "Start Mozilla"


Actual Results:  Mozilla did not open, but remained on the end task screen.  
When I end Mozilla there, I get an illegal operation. 



Expected Results:  Mozilla should have opened.

MOZILLA caused a divide error in module APPCOMPS.DLL at 018f:6007012b.
Registers:
EAX=00000000 CS=018f EIP=6007012b EFLGS=00010246
EBX=00000001 SS=0197 ESP=0068fb98 EBP=0068fbd8
ECX=00000000 DS=0197 ESI=01c63840 FS=294f
EDX=00000000 ES=0197 EDI=00000000 GS=0000
Bytes at CS:EIP:
f7 f1 8b d8 8b 44 24 10 f7 f1 8b d3 eb 41 8b d8 
Stack dump:
00000001 01c63840 00000000 6005eab4 00000000 00000000 00000000 00000000 
0000002c 01c63850 01c63840 01c8d2e8 00000000 00000000 00000000 011939f8
(Reporter)

Comment 1

17 years ago
I forgot to mention that another, similar identity works just fine.  The OK 
identity was not used nearly as much (and I assume is much more default)

Comment 2

17 years ago
In Mozilla identities are called "profiles", and if it works with a new profile,
then it is a migration problem. Also please provide a correct buildID (20001218?
we're only the 17th...). I suggest you try to remove some files from your ns4
profile and see if it works then... however I am not sure we are supposed to
handle ns3 migrated profiles.. that's a bit old..
Anyway over to migration.
Assignee: asa → dbragg
Component: Browser-General → Profile Migration
QA Contact: doronr → gbush
(Reporter)

Comment 3

17 years ago
sorry.  I said it was migrated to netscape 4.x from 3.0, thats not true.  It 
was migrated from Netscape 4.x to Netscape 6.0 (with preview relase 1 I think)
It works fine in Netscape 6, and does not work in Mozilla, including 0.6

it was late last night when I wrote the bug.  Build 2000121508 I think, as well 
as 0.6

I don't think this is a migration issue.

I'm sure there is an easy workaround -- create a new identity.
However, I think that perhaps it is not an isolated problem.

I guess it would make sense to downgrade this to minor, sorry.

Comment 4

17 years ago
If it was migrated form 3.x to 4.x and tehn to mozilla there is a bug on that
being problematic (can't find it but it's there).  If it was migrated to
Netscape 6 there seems to be an incompatability between some netscape 6 profiles
and current mozilla builds.  
(Reporter)

Comment 5

17 years ago
It definitely originated in Netscape 4.x, and was converted to Netscape 6 with 
preview release 1.

Comment 6

17 years ago
I think that is bug 11084
Lots of things changed between PR1 and RTM and we recommend removing profiles 
created earlier in N6.  You can migrate the 4.x profile again however rather 
than create a new N6 profile.  The installation of N6 should look for registered 
4.x profiles and either migrate a single one or offer you a choice if more than 
one exists.  (to simulate this run from the command line in the netscape 6 
directory.....netscp6 -installer)
(Reporter)

Comment 7

17 years ago
bug 11084, eh?

Funny, I can't read bug 11084... why's that?

Yeah that fixes it.  I guess you can resolve it.

Comment 8

17 years ago
working now
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME

Comment 9

17 years ago
vfy
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.