Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Decrease update interval length for nightly users

RESOLVED FIXED in Firefox 9

Status

()

Firefox
Preferences
RESOLVED FIXED
7 years ago
6 years ago

People

(Reporter: jrmuizel, Assigned: jrmuizel)

Tracking

Trunk
Firefox 9
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 4 obsolete attachments)

(Assignee)

Description

7 years ago
The interval is currently 8 hours, it would be nice if this could be shorter for nightly users.
(Assignee)

Updated

7 years ago
Blocks: 630878
Not sure if this would help significantly... this could very well be due to not notifying users to restart until 12 hours have elapsed.

This and the notification after 12 hours have elapsed are controlled by app preferences so moving over to Firefox preferences.
Component: Application Update → Preferences
Product: Toolkit → Firefox
QA Contact: application.update → preferences
Version: unspecified → Trunk
OS: Mac OS X → All
Hardware: x86 → All
Daniel, does this have any implications for metrics ? The proposal is to query AUS more frequently for updates.
We don't use AUS for metrics.  We already bumped the AUS check for nightlies from 24 hours to 8 a while back.  Going even further has no additional impact on metrics.  Thanks for checking.
mrz, any problem with load if we increase the update check frequency again for nightly users from every 8 hours to 4 or 2 hours?

Comment 5

7 years ago
no, no blockers from me.
(Assignee)

Comment 6

7 years ago
Created attachment 511408 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours
Attachment #511408 - Flags: review?
(Assignee)

Updated

7 years ago
Attachment #511408 - Flags: review? → review?(robert.bugzilla)
Comment on attachment 511408 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours

Jeff, are you trying to get this in for Firefox 4.0? I highly suspect that due to what I mentioned in comment #1 this won't have a large impact and that the restart nag timer will also need to be moved to branding and shortened as well.
Comment on attachment 511408 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours

I don't want to take this change without a change to app.update.nagTimer.restart as well.
Attachment #511408 - Flags: review?(robert.bugzilla) → review-
(Assignee)

Comment 9

6 years ago
Created attachment 522856 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v2

This moves the nag timer in to branding
Attachment #511408 - Attachment is obsolete: true
Attachment #522856 - Flags: review?(robert.bugzilla)
Comment on attachment 522856 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v2

Looks good to me but I am not a peer of this code so asking Gavin for review.

Gavin, I suspect it might be better if unofficial branding used the same values as release since if I am correct it is used by 3rd party builds.
Attachment #522856 - Flags: review?(robert.bugzilla)
Attachment #522856 - Flags: review?(gavin.sharp)
Attachment #522856 - Flags: review+
Comment on attachment 522856 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v2

This results in the app.update.nagTimer.restart pref not being defined in official builds, because you're removing it from firefox.js but not adding it to other-licenses/branding/firefox/pref/firefox-branding.js.
Attachment #522856 - Flags: review?(gavin.sharp) → review-
Comment on attachment 522856 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v2

bah... I forgot that the usage of the nagTimer.restart pref was removed a while ago so it is no longer needed. When there is an update downloaded and staged to be applied the idle timer is used to wait for 60 seconds of idle time after the unobtrusive notification before showing the update ui.

For manual updates app.update.promptWaitTime handles the amount of time until the display of the update ui and the update service has a default value of 43200.

So, it would be best to just remove the nagTimer pref.
(Assignee)

Comment 13

6 years ago
Created attachment 525040 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v3
Attachment #522856 - Attachment is obsolete: true
Attachment #525040 - Flags: review?
(Assignee)

Updated

6 years ago
Attachment #525040 - Flags: review?(robert.bugzilla)
Attachment #525040 - Flags: review?(gavin.sharp)
Attachment #525040 - Flags: review?
You'd still need to update the comment in the official branding firefox-branding.js. But it's probably better to just remove the values from that comment and instead add them on the line itself, e.g.:

// Interval: Time between checks for a new version (in seconds)
// nightly=6 hours, official=24 hours
pref("app.update.interval", 86400);

=>

// Interval: Time between checks for a new version (in seconds)
pref("app.update.interval", 86400); // 24 hours
Comment on attachment 525040 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v3

I'm fine with this change. Gavin owns this code so I don't need to r+ this patch or future versions.
Attachment #525040 - Flags: review?(robert.bugzilla)
Comment on attachment 525040 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v3

Now that bug 648368 landed you also need to update branding/aurora. r=me with that and comment 14 addressed.
Attachment #525040 - Flags: review?(gavin.sharp) → review+
No longer blocks: 630878
Duplicate of this bug: 630878
(Assignee)

Comment 18

6 years ago
Created attachment 554079 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v4

This is simpler because the nagTimer is gone.
Attachment #525040 - Attachment is obsolete: true
Attachment #554079 - Flags: review?
(Assignee)

Updated

6 years ago
Attachment #554079 - Flags: review? → review?(gavin.sharp)
Comment on attachment 554079 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v4

The general idea seems fine, and the right branding packages are being flipped here (though "unofficial" branding is now generally unused - we should probably remove it).

Rob Strong should probably sign off on whether there are other prefs that need to change, or whether app update will handle this short of an interval correctly.

And you still need to address comment 14 :)
Attachment #554079 - Flags: review?(gavin.sharp)
Attachment #554079 - Flags: review+
Attachment #554079 - Flags: feedback?(robert.bugzilla)
(Assignee)

Comment 20

6 years ago
Created attachment 554157 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v5

This takes the approach from comment 14
Attachment #554079 - Attachment is obsolete: true
Attachment #554157 - Flags: feedback?(robert.bugzilla)
Attachment #554079 - Flags: feedback?(robert.bugzilla)
Comment on attachment 554157 [details] [diff] [review]
Decrease the interval from 8 hours to 2 hours v5

We don't use branding/unofficial for any of our builds and I am kind of leaning towards its value being 86400 since the only time it will be used is with custom builds. Otherwise I'm fine with this.
Attachment #554157 - Flags: feedback?(robert.bugzilla) → feedback+
http://hg.mozilla.org/mozilla-central/rev/ca798b7e74ef
Assignee: nobody → jmuizelaar
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 9
You need to log in before you can comment on or make changes to this bug.