Closed Bug 630885 Opened 9 years ago Closed 9 years ago

Sync key listed as undefined and generates an error on 'Change Sync Key'

Categories

(Firefox :: Sync, defect)

defect
Not set

Tracking

()

VERIFIED FIXED
Tracking Status
blocking2.0 --- final+

People

(Reporter: aaronmt, Assigned: philikon)

References

Details

(Keywords: regression, Whiteboard: [softblocker])

Attachments

(4 files)

Attached image Undefined error
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

Seemingly the simple step to restore my sync account is proving to be a pain as when I attempt to change my sync key, sync will display 'undefined' and on click of generate, and click of change sync key, I get "There was an error while changing your Sync key!"

Perhaps two issues, but both are preventing me from moving on from this step in the wizard.

See attached screenshot
blocking2.0: --- → ?
Component: Server: Sync → Firefox Sync: UI
QA Contact: sync-server → sync-ui
This WFM, with the Mac minefield nightly of 20110202.
I can reproduce this. This is because we don't actually set the account name and password before we go to the Change Sync Key dialog (via the "I have lost my other device" link).
Ah, ok, I see that now. So we need to disable that link 'til you enter account name and password? 

If you forget everything, well, you're done with account.
(In reply to comment #4)
> Ah, ok, I see that now. So we need to disable that link 'til you enter account
> name and password?

Yes, something like that. We should definitely make it verify account + password before sending you to that other window.
Oh even if you entered your email and password, changing the sync key via that link doesn't work.  I think the only way out in this case is to delete-account and start over.  Not the best work-around.

Definitely verify account in there somewhere.
Flags: in-litmus?
(In reply to comment #6)
> Oh even if you entered your email and password, changing the sync key via that
> link doesn't work.  I think the only way out in this case is to delete-account
> and start over.  Not the best work-around.

Yep, as I said in comment 3, we don't actually take the values from the form fields and store them in Sync's credentials...

Working on a fix...
Assignee: nobody → philipp
Status: NEW → ASSIGNED
OS: Mac OS X → All
Hardware: x86 → All
Ensure all the right bits are set and checked when resetting the Sync Key from the now all-in-one manual sign in page.

This makes it work again, but it's not 100% awesome. The user still has to click on "Generate" in the "Change Sync Key" dialog. Part 2 is fixing that.
Attachment #509306 - Flags: review?(mconnor)
Don't make the user click on "Generate" before the 'Change Sync Key' dialog can be dismissed.
Attachment #509307 - Flags: review?(mconnor)
Whiteboard: [softblocker?][has patch][needs review mconnor]
blocking2.0: ? → final+
Whiteboard: [softblocker?][has patch][needs review mconnor] → [softblocker][has patch][needs review mconnor]
Duplicate of this bug: 601456
Attachment #509306 - Flags: review?(mconnor) → review+
Attachment #509307 - Flags: review?(mconnor) → review+
Whiteboard: [softblocker][has patch][needs review mconnor] → [softblocker][has patch][has review]
Pushed to places:

Part 1: http://hg.mozilla.org/projects/places/rev/2926f4941ab3
Part 2: http://hg.mozilla.org/projects/places/rev/90a18a0b6438
Whiteboard: [softblocker][has patch][has review] → [softblocker][fixed in places]
Landed on m-c:

Part 1: http://hg.mozilla.org/mozilla-central/rev/2926f4941ab3
Part 2: http://hg.mozilla.org/mozilla-central/rev/90a18a0b6438
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [softblocker][fixed in places] → [softblocker]
verified with beta12 against stage-auth.
Status: RESOLVED → VERIFIED
Blocks: 684536
No longer blocks: 615950
removing in-litmus flag, it no longer exists
Flags: in-litmus?
Component: Firefox Sync: UI → Sync
Product: Cloud Services → Firefox
You need to log in before you can comment on or make changes to this bug.