Closed Bug 630940 Opened 9 years ago Closed 9 years ago

stop running unittests on build machines for releases

Categories

(Release Engineering :: General, defect, P4)

x86_64
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

For 1.9.2 and mozilla-central we already run release tests on test machines, we should just disable the build machine runs.

For 1.9.1, we don't do any testing on release builds on test machines, but I don't see why we shouldn't be able to.
The reason we didn't is because the perma-oranges that got fixed for enabling unit tests on the minis would require backporting which is not free.

That is why we decided not to enable unit tests on the minis for 1.9.1 and 1.9.2.
Priority: -- → P4
(In reply to comment #0)
> For 1.9.2 and mozilla-central we already run release tests on test machines, we
> should just disable the build machine runs.
>
I am sorry I did not catch this at first.
We do *not* run unit tests on the test machines for 1.9.2 (nor for normal builds neither for releases).
http://hg.mozilla.org/build/buildbot-configs/file/69e900bf01ea/mozilla-tests/config.py#l499

Unfortunately, we have to keep on running unit tests on the builders unless you think you can convince developers to back port the test fixes they had to land for clearing perma-oranges.

I vote for WONTFIX.
for mozilla-central builds, we shouldn't be running tests on builders though
(In reply to comment #3)
> for mozilla-central builds, we shouldn't be running tests on builders though

It is disabled on the builders (but not for releases which has to be fixed - I have it assigned).
Armen is referring to bug 631546. I think we should fix that there. If we're running tests on minis for 1.9.2 then we should find out why, otherwise I think there's nothing else to do here.
(In reply to comment #1)
> The reason we didn't is because the perma-oranges that got fixed for enabling
> unit tests on the minis would require backporting which is not free.
> 
> That is why we decided not to enable unit tests on the minis for 1.9.1 and
> 1.9.2.

Are you sure this is accurate for 1.9.2? I see tons of 1.9.2 tests running on minis...
bhearsum are you sure you are not looking at the talos jobs?

This is how it should be:
* 1.9.1/1.9.2 talos on minis
* 1.9.1/1.9.2 unit tests on builders

Can we please close this bug? or am I missing something?
Ah, you're right. Sorry for the confusion!
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.