about:home snippets appear blank; profile contains empty snippets from 2010-10-22

VERIFIED INVALID

Status

()

Firefox
General
VERIFIED INVALID
8 years ago
7 years ago

People

(Reporter: mbrubeck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [about-home])

(Reporter)

Description

8 years ago
In the main Firefox profile on my Linux box running Minefield trunk nightlies, the snippet area on about:home is empty (looks like a blank white button).

localStorage.snippets on about:home contains the following value:

<div class="snippet_set"><!-- content generated at 2010-10-22T21:07:11Z --></div>

As far as I know, I have never manually changed any browser.startup or browser.aboutHomeSnippets prefs.

I don't see this problem in any other profiles.  Is this just a remnant from some test deployment last October, which will be fixed when bug 592431 is deployed?
There was a point where snippets.mozilla.com was briefly pointed at staging, probably for a day, and 2010-10-22 sounds about right.

Your Firefox probably picked up the empty snippet content from back then, and retained it as it's meant to do after the server went away. 

There hasn't been a live snippets.mozilla.com since then, so there hasn't been an update. When there is a live service again, snippets from it should replace whatever's in your localStorage

I wouldn't call this a bug, per se, until or unless the service goes live and you see no snippet updates
(Reporter)

Comment 2

8 years ago
I'll resolve this as invalid, since the code is working as designed.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID

Updated

8 years ago
Whiteboard: [about-home]
(Reporter)

Comment 3

7 years ago
This is no longer blank now that the snippet service is running.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.