Canvas graph on input.mozilla.com redraws when findbar opened/closed

RESOLVED DUPLICATE of bug 631102

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 631102
7 years ago
7 years ago

People

(Reporter: jdm, Unassigned)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Go to input.mozilla.com, then open the findbar after the page loads.  Watch the graph redraw from scratch.  Close the findbar, watch it do so again.
(Reporter)

Updated

7 years ago
blocking2.0: --- → ?
What's "the findbar"?
That being said, some context here, the graph is redrawn on the "resize" JS event. So it redraws because what you are doing is firing such an event, and if the page is indeed resizing then the graph must be redrawn to fit its new constraints. Then this would be expected and not a bug.

If your action is not in fact resizing the window, then Firefox should not fire a resize event, in which case this is a client bug.
(Reporter)

Comment 3

7 years ago
The findbar is the toolbar that pops up giving you the ability to search the page.  Ctr+F?  I guess I am surprised that bringing up a chrome toolbar would have a possibility of resizing a page, since it's just an overlay.

Updated

7 years ago
Blocks: 631102
Ah, thanks for clarifying this! This is currently expected, but your bug made me think, and it turns out we don't need to redraw on vertical size changes, only horizontal ones. So I filed bug 631102 over on Input. Since I do believe the resize JS event is fired correctly here (ergo, not a client bug), let me dupe this over to the Input enhancement I filed. It'll automatically CC you on that bug.

Thanks again!
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 631102
(Reporter)

Updated

7 years ago
blocking2.0: ? → ---
You need to log in before you can comment on or make changes to this bug.