Wrong ff version in /sites dropdown

VERIFIED FIXED in 3.1

Status

P1
major
VERIFIED FIXED
8 years ago
8 years ago

People

(Reporter: mbrandt, Assigned: michaelk)

Tracking

({regression})

other
regression

Details

(Whiteboard: [fromAutomation])

(Reporter)

Description

8 years ago
Going to link (http://input.stage.mozilla.com/en-US/beta/site/http/bodybrowser.googlelabs.com) wrong ff version in product drop down for 3.6.
Great find!
Michael, can I give that to you? What seems to happen here is that ``apps/website_issues/forms.py:16``:

VERSION_CHOICES = VERSION_CHOICES[get_channel()].copy()

... gets executed at load time, so the version choices are stuck to a single channel for the remainder of this Python thread's lifetime.

Long story short, since we have code for both the beta and release pages now, I am thinking this bug might already be fixed in your code: Just double-check that that's the case. Thanks!
Assignee: nobody → michael
Severity: normal → major
Priority: -- → P1
This is causing a failure in the Selenium test suite.
Keywords: regression
Whiteboard: [fromAutomation]
(Assignee)

Comment 4

8 years ago
Fixed: The version list should be OK again.

https://github.com/fwenzel/reporter/commit/4f2594dcb1a127f7a80a1d587495856bdbad0995
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

8 years ago
QA verified, the list has the proper values in it.
Status: RESOLVED → VERIFIED
Component: Input → General
Product: Webtools → Input
You need to log in before you can comment on or make changes to this bug.