Default bookmark folders should be localizable

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
P3
normal
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Karl Ove Hufthammer, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Trunk
mozilla1.0.1

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
The names of the default bookmark folders ('Personal Toolbar', 'Mozilla 
Project' and 'Imported IE favorites') should be localizable. They currently 
(2000-12-15) are not.
(Reporter)

Updated

17 years ago
Blocks: 12394

Comment 1

17 years ago
I am using Build 2000121514 with Mac OS 9.0.4.  When I go to "Manage
Bookmarks..." under the "Bookmarks" menu, I have three sections.  That is, I
have two thin black lines that run the length of the window horizontally, thus
creating three seperate sections.  This also matches up with the division of my
"Bookmarks" menu.  I can move my "Personal Toolbar Folder" to any location
within the three divisions.  However, I cannot move the "Imported IE Favorites"
from its current location.  I would have to say "confirmed" and "new", but I do
not have the priviliges to do so.  Maybe somebody could give them to me?  ;-)

Comment 2

17 years ago
Reassigned to Allan for the Bookmark issue.
Assignee: rchen → amasri

Comment 3

17 years ago
Jonathan Abrams : your issue is not the same. That is part of the "Imported IE
favorites should act as a usual bookmark folder" bug, you'll find it easily in
Bugzilla.
Karl Ove, I'll try to look at it. Given that all your bug reports are correct,
i'm marking this New (I'll get you bugzilla priviledges so you can set them to
New directly)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: mozilla0.9, nsbeta1

Comment 4

17 years ago
Taking this.
Assignee: amasri → blakeross

Comment 5

17 years ago
This actually appears to be done already. The only remaining hardcoded 
reference seems to be 
http://lxr.mozilla.org/seamonkey/source/xpfe/components/bookmarks/src/nsBookmark
sService.cpp#158, and that's just the default we fall back on if we can't 
retrieve it from the properties file for whatever reason. Marking fixed.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 6

17 years ago
Changed QA contact to andreasb@netscape.com.
QA Contact: teruko → andreasb

Comment 7

17 years ago
Changing QA Contact to jonrubin@netscape.com
QA Contact: andreasb → jonrubin

Comment 8

17 years ago
Not clear how to verify this; is there a testcase that I can use to verify this? 
Do I need to wait until a language pack becomes available?
(Reporter)

Comment 9

17 years ago
It only works if you create a completely *new* user profile (you loose all your
mail, preferences and bookmarks) and choose the appropiate region pack.

Also note that you have to use your current profile to download and install that
region pack.

Comment 10

17 years ago
Reopening - Following Karl's testcase, I did not see localized bookmark folders
after creating a new profile and selecting a new region (the "Imported IE
Favorites" folder, however, was localized).  This is probably dependent on
Bugscape 6828, in which a new region does not get applied when selecting through
profile manager.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

17 years ago
Note that my last comment was based on testing with 6.1b build (20010607).

Comment 12

17 years ago
cc nhotta

Comment 13

17 years ago
Patch of bug 80230 may fix this problem, cc to katakai@japan.sun.com and
jbetak@netscape.com.
including Tao's comment from bug 65251, cc'ing Tao. Apparently, profile-bound 
resources are not localizable after a profile has been created to prevent loss 
of user-customized data. See below:

...

>As for Content packs - I don't know a great deal about how they work as the
>explanation provided isn't terribly detailed.

Please refer to http://www.mozilla.org/projects/l10n/mlp_regional.html#regional

> Does this mean that if I 
>switch packs, all my bookmarks I collected in pack A are gone?

No, bookmarks and other profile-bound resources are not switchable once
the profile is created.

> Why do I need
>to switch locale packs anyway to adjust bookmarks, isn't that what our
>bookmarking system, complete with the ability to organize things into folders,
>is for?

"Regional pack" switching affects the locality of the default bookmarks which
is copied from "[install-dir]/defaults/profile/[region-code]/bookmarks.html"
into user profile directory. Once it is created; it's NOT switchable since 
it might contain user's customization (addition/edit/deletion) which we don't
want to tamper with.

"Regional switching" do affect the taskbar, Search menu, Home Page URL, etc. 

Feel free to let me know if more details is needed.



another comment: I just applied the 0.9.1 JP region pack to a trunk build 
(using Katakai's patch) and although most default bookmarks, the Sidebar and 
other things are Japanese, "Imported IE Favorites" is still glaring in 
the "Bookmarks" menu. Wasn't that the original complaint raised by Karl? Jon, 
maybe we need to retest using 0.9.2 content packs to confirm.

Comment 16

17 years ago
--> Bookmarks
Assignee: blake → ben
Status: REOPENED → NEW
Component: Localization → Bookmarks
QA Contact: jonrubin → claudius
nav triage: we would like to look at this early in the mach V timeframe. we will 
not do this for eMojo. 
Priority: -- → P3
Target Milestone: --- → mozilla1.0.1

Updated

17 years ago
Keywords: nsbeta1 → nsbeta1+

Comment 18

17 years ago
The bookmarks folders mentioned here are defined within the bookmarks.html. To
localize the folder names, you'd need to localize the corrresponding entries in
bookmarks.html. 
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen

Comment 20

16 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 21

16 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.2b) Gecko/20021003

steps:
install the german language pack.
quit mozilla
run mozilla -ProfileManager
create profile
next
region selection
preferred content: Inhalte: Österreich
(optional) preferred language: Deutsch
ok
finish

result: bookmarks include the mozilla de-at site, imported favorites is spelled
in German.

There is an import bookmarks feature (which may work). anyone who needs foreign
bookmarks after the fact is free to use it. if it doesn't work they're free to
search for a matching bug in bugzilla and failing that to file one.
Status: NEW → RESOLVED
Last Resolved: 17 years ago16 years ago
Resolution: --- → WORKSFORME
See comment 9 and comment 14. Some people expect that a region pack will change
default bookmark folders names to its corresponding locale. We have deliberately
decided no to do so. I support wonfixing this, if there is not enough user interest.

huftis, do you still care about this thing? What are your latest thoughts on this?
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.