Search autocomplete popup opens in the wrong position in RTL mode

VERIFIED FIXED in Firefox 5

Status

()

defect
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: Ehsan, Assigned: Ehsan)

Tracking

({rtl})

Trunk
Firefox 5
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments, 2 obsolete attachments)

Assignee

Description

9 years ago
Posted image Screenshot
See the screenshot.
Assignee

Updated

9 years ago
blocking2.0: --- → ?
Ehsan, does it happen on all platforms? Would be good to know between which beta releases it has been regressed.
Version: unspecified → Trunk
I've tested on both linux and win32 platoforms. The popup appears in its right place there. See the second screenshot.
So this is an OS X only issue? Ehsan, are you using multiple screens?
Assignee

Comment 5

9 years ago
(In reply to comment #4)
> So this is an OS X only issue? Ehsan, are you using multiple screens?

I haven't tested on other platforms, and no, I wasn't been using multiple screen.
Also happens in 3.6.13 builds of ar on OS X. I'm sure this is a dupe of another bug.
Whiteboard: [DUPEME]
Assignee

Comment 7

9 years ago
I could reproduce this on Hebrew trunk builds on all platforms.
OS: Mac OS X → All
Hardware: x86 → All
Assignee

Comment 8

9 years ago
Posted patch Patch (v1) (obsolete) — Splinter Review
We shouldn't really think that we can position the popup better than the xul popup manager code!
Assignee: nobody → ehsan
Status: NEW → ASSIGNED
Attachment #509525 - Flags: review?(gavin.sharp)
Assignee

Comment 9

9 years ago
Henrik, please dupe any other bugs on this you can find against this one, as it has a patch.
Whiteboard: [DUPEME]
Comment on attachment 509525 [details] [diff] [review]
Patch (v1)

This method really needs to be synced with autocomplete.xml's _openAutocompletePopup (and I don't think you want to be removing the width setting). We may be able to do that by just removing this override entirely, but we need to make sure not to regress bug 398020 comment 24 (aligning the popup with the text field itself, rather than the engine selector dropdown).
Attachment #509525 - Flags: review?(gavin.sharp) → review-
Assignee

Comment 11

9 years ago
Posted image With patch, LTR
Assignee

Comment 12

9 years ago
Posted image With patch, RTL
Assignee

Comment 13

9 years ago
Posted patch Patch (v2) (obsolete) — Splinter Review
Attachment #509525 - Attachment is obsolete: true
Attachment #509634 - Flags: review?(gavin.sharp)
Assignee

Updated

9 years ago
Attachment #509634 - Flags: approval2.0?
Assignee

Comment 14

9 years ago
Actually it's not a regression...
blocking2.0: ? → ---
Assignee

Updated

9 years ago
Duplicate of this bug: 405968
(In reply to comment #14)
> Actually it's not a regression...

Are you sure about that? In the second attachment, taken from a linux64 build of fx4 beta that was built a couple of weeks ago, the popup appears in its proper place. However, I have just made a new linux64 build where I've found that the popup is shifted from its expected place. It seems that the cause was probably landed in mozilla-central in that short period.
Do you have a closer time range for Linux?
Assignee

Comment 18

9 years ago
(In reply to comment #16)
> (In reply to comment #14)
> > Actually it's not a regression...
> 
> Are you sure about that? In the second attachment, taken from a linux64 build
> of fx4 beta that was built a couple of weeks ago, the popup appears in its
> proper place. However, I have just made a new linux64 build where I've found
> that the popup is shifted from its expected place. It seems that the cause was
> probably landed in mozilla-central in that short period.

Yes, I'm sure (judging by reading the faulty code, and how long it goes back, and actually testing on 3.6!).

Please note that according to the exact place of the Firefox window on the screen, there is a slight possibility that you would see the autocomplete popup in the right position, but that's an exception, and moving the window on the screen reveals the problem.
Assignee

Comment 19

9 years ago
Comment on attachment 509634 [details] [diff] [review]
Patch (v2)

Gavin: I think this is a nice fix to take for RTL locales.  It's not a blocker by any means, but if you had a few spare cycles, I'd really appreciate if you can take a look at this.
Attachment #509634 - Flags: approval2.0?
Assignee

Comment 20

8 years ago
Gavin: ping?
Comment on attachment 509634 [details] [diff] [review]
Patch (v2)

Can you add a comment to the top of this method along the lines of:

"This method overrides the autocomplete binding's openPopup (essentially duplicating the logic from the autocomplete popup binding's openAutocompletePopup method), modifying it so that the popup is aligned with the inner textbox, but sized to not extend beyond the search bar border."
Attachment #509634 - Flags: review?(gavin.sharp) → review+
Assignee

Comment 22

8 years ago
Posted patch For check-inSplinter Review
Attachment #509634 - Attachment is obsolete: true
Assignee

Comment 23

8 years ago
http://hg.mozilla.org/mozilla-central/rev/be9814a5a456
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox4.2

Comment 24

8 years ago
Verified on Mozilla/5.0 (Windows NT 6.1; rv:2.2a1pre) Gecko/20110403 Firefox/4.2a1pre

Search autocomplete popup opens in the wright position.
Status: RESOLVED → VERIFIED
Target Milestone: Firefox5 → Firefox 5
Duplicate of this bug: 666749
You need to log in before you can comment on or make changes to this bug.