Closed Bug 631179 Opened 9 years ago Closed 7 years ago

Intermittent test failure and timeout in browser/components/sessionstore/test/browser/browser_464199.js involving nsIIndexedDatabaseManager.clearDatabasesForURI

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows 7
defect
Not set

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: roc, Unassigned)

References

Details

(Keywords: intermittent-failure)

See
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296722656.1296726411.31340.gz#err2

TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_464199.js | Closed tab list has the expected length
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_464199.js | The correct amout of tabs are to be forgotten
TEST-PASS | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_464199.js | Everything is set up.
WARNING: An event was posted to a thread that will never run it (rejected): file e:/builds/moz2_slave/cen-w32-dbg/build/xpcom/threads/nsThread.cpp, line 386
WARNING: Failed to dispatch to IO thread!: file e:/builds/moz2_slave/cen-w32-dbg/build/dom/indexedDB/IndexedDatabaseManager.cpp, line 884
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0x80004005: file e:/builds/moz2_slave/cen-w32-dbg/build/dom/indexedDB/IndexedDatabaseManager.cpp, line 777
JavaScript error: , line 0: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIIndexedDatabaseManager.clearDatabasesForURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/components/nsPrivateBrowsingService.js :: PBS_removeDataFromDomain :: line 690"  data: no]
WARNING: Nv3DVStreaming CoCreateInstance failed (disabled).: file e:/builds/moz2_slave/cen-w32-dbg/build/gfx/layers/d3d9/Nv3DVUtils.cpp, line 85
###!!! ASSERTION: Huh?!: '!mPendingEventCount', file e:/builds/moz2_slave/cen-w32-dbg/build/dom/indexedDB/LazyIdleThread.cpp, line 302
TEST-INFO | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_464199.js | Console message: [JavaScript Error: "uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIIndexedDatabaseManager.clearDatabasesForURI]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: resource://gre/components/nsPrivateBrowsingService.js :: PBS_removeDataFromDomain :: line 690"  data: no]"]
++DOMWINDOW == 279 (18AEABB0) [serial = 3144] [outer = 1B758A40]
TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/components/sessionstore/test/browser/browser_464199.js | Test timed out
Blocks: 438871
Summary: Intermittent test failure involving nsIIndexedDatabaseManager.clearDatabasesForURI → Intermittent test failure and timeout in browser/components/sessionstore/test/browser/browser_464199.js involving nsIIndexedDatabaseManager.clearDatabasesForURI
Depends on: 631452
Pretty sure this will be fixed by bug 631452.
Justin Lebar [:jlebar] said in bug 717019 comment #1:
> I think the problem is that I'm querying example.net,
> which is a real, live page, when I should be querying example.org,
> which is a fake mochitest page.

browser_464199.js uses example.net as well, should it be changed?
Mass marking whiteboard:[orange] bugs WFM (to clean up TBPL bug suggestions) that:
* Haven't changed in > 6months
* Whose whiteboard contains none of the strings: {disabled,marked,random,fuzzy,todo,fails,failing,annotated,leave open,time-bomb}
* Passed a (quick) manual inspection of bug summary/whiteboard to ensure they weren't a false positive.

I've also gone through and searched for cases where the whiteboard wasn't labelled correctly after test disabling, by using attachment description & basic comment searches. However if the test for which this bug was about has in fact been disabled/annotated/..., please accept my apologies & reopen/mark the whiteboard appropriately so this doesn't get re-closed in the future (and please ping me via IRC or email so I can try to tweak the saved searches to avoid more edge cases).

Sorry for the spam! Filter on: #FFA500
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → WORKSFORME
Whiteboard: [orange]
You need to log in before you can comment on or make changes to this bug.