Overlay for connecting / waiting / loading status messages is no longer "small"

VERIFIED FIXED

Status

()

Firefox
General
VERIFIED FIXED
7 years ago
7 years ago

People

(Reporter: geeknik, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

7 years ago
Now that Bug 541656 and Bug 629898 have landed, the "small" overylay is no longer the width of the URL being loaded. 

http://imgur.com/7pZ4B.jpg

I hope this is not by design because it looked a lot nicer when the overlay matched the width of the URL being loaded and not like this generic static width.

Updated

7 years ago
OS: Windows 7 → All
Hardware: x86_64 → All
This is pretty much the point of bug 629898.
I think 25% might be too much for large screens...
Blocks: 629898

Comment 3

7 years ago
I don't think. Chrome's status panel always stays at 33% and changes size only when I stay with mouse over very long link for 1 or 2 sec (then the max width increased to 100% and show full url). Min width is never less than 33%.

Comment 4

7 years ago
To comment 3, why care what Chrome doe or is Mozilla now just copying everything from Chrome.
Duplicate of this bug: 631638
(In reply to comment #4)
> To comment 3, why care what Chrome doe or is Mozilla now just copying
> everything from Chrome.

Because it is always useful to look at what works for other browsers. This does not imply "copying everything". Your unnecessarily hostile comment is not helpful.

Comment 7

7 years ago
Is this fixed?
Because it does not happen for me.There seems to be some minimal width that should be removed in favor of very short urls tho i guess minwidth is implemented to give it some consistency(meaning it does not jump around all the time with short url-s).

Comment 8

7 years ago
(In reply to comment #7)
> Is this fixed?
> Because it does not happen for me.There seems to be some minimal width that
> should be removed in favor of very short urls tho i guess minwidth is
> implemented to give it some consistency(meaning it does not jump around all the
> time with short url-s).

Seems like it: https://bugzilla.mozilla.org/show_bug.cgi?id=629898
(Reporter)

Comment 9

7 years ago
I believe that https://bugzilla.mozilla.org/show_bug.cgi?id=631298 is going to fix the reason I had for opening this bug. Once I verify it, I will be closing this bug.

Comment 10

7 years ago
I think it is now fixed in latest nighly.
(Reporter)

Comment 11

7 years ago
Doesn't look like it. When you hover over a link, the overlay width matches the length of the URL now, which is how it was to begin with, but the connecting/waiting/loading messages are still wider than the URL as shown the image in my first comment.

Comment 12

7 years ago
Yes, we need to make connecting messages take up as little space as possible. I feel that bug 629898 is pretty invalid because jitter is irrelevant when its on the right side of a sentence, at least for LTR languages. Jitter only matters when its on the left side because it would be hard to start reading a moving target.

This bug should be fixed because most of the time the connecting messages do not take up the full length of the overlay background. We're just using unnecessary space here that we could be using to look at web content.
(Reporter)

Comment 13

7 years ago
This looks like it is now fixed. I'm using an hourly Firefox 4.0b13pre build (Built from http://hg.mozilla.org/mozilla-central/rev/c60c4769c89a)and the width of the overlay now matches the width of the information being displayed inside of it. Closing as FIXED.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED

Comment 14

7 years ago
 Mozilla/5.0 (X11; Linux i686; rv:2.0) Gecko/20100101 Firefox/4.0

Verified issue and it's no longer present.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.