caret disappears in text boxes and design mode

RESOLVED INCOMPLETE

Status

()

Core
Widget: Win32
--
major
RESOLVED INCOMPLETE
7 years ago
5 years ago

People

(Reporter: Giorgio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: Needs STR)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110131 Firefox/4.0b11pre
Build Identifier: 

I can't reproduce the issue but I think it is related to transparent layers drawing and cleartype

I mark it "major" because it happens frequently

for example, in a html document caret disappears when something changes its opacity

cleartype disappears for a millisecond, then reappears, 
input works, keyboard and mouse caret control works, 
but the caret (in any other position, not only in the transparent div) is no more visibile

I'm pretty sure that this do not happen in firefox 4 beta 9 but I'm sure happens in

xulrunner:                   Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b10pre) Gecko/20110124
nearly latest trunk of ff4:  Mozilla/5.0 (Windows NT 6.1; WOW64; rv:2.0b11pre) Gecko/20110131 Firefox/4.0b11pre

my system:
windows 7 ultimate x64 with aero enabled

Reproducible: Couldn't Reproduce
Keywords: qawanted
Whiteboard: Needs STR
Giorgio, are you still able to reproduce this issue? Could you please give some steps to reproduce? What URL (html document) are you using?
Flags: needinfo?(giorgio.liscio)
Closing as Incomplete based on lack of activity.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Keywords: qawanted
Resolution: --- → INVALID
Resolution: INVALID → INCOMPLETE

Updated

5 years ago
Flags: needinfo?(giorgio.liscio)
You need to log in before you can comment on or make changes to this bug.