Full zooming doesn't work with SVG on Mac 10.5

RESOLVED WORKSFORME

Status

()

Core
SVG
RESOLVED WORKSFORME
7 years ago
7 years ago

People

(Reporter: Teodosia Pop, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [4b11], URL)

(Reporter)

Description

7 years ago
Build ID: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b11) Gecko/20100101 Firefox/4.0b11

Steps to Reproduce:
1. Visit http://upload.wikimedia.org/wikipedia/en/e/e3/Firefox-logo.svg
2. Use Control+(+/-) (Cmd+(+/-) on Mac) to zoom in/out the page. You can also use the view command from the File Menu to zoom in and out, as well as reset the page.

Actual Results:
The image is not zoomed.

Expected Results:
1. After Step 2, you should be able to zoom in/out on the Firefox logo on the page.
(Reporter)

Updated

7 years ago
WORKSFORME in today's nightly on Ubuntu Linux and on Mac OS 10.6. (I don't have an OS X 10.5 box immediately available to test this on, but I'd expect it should behave like 10.6.)

Mozilla/5.0 (X11; Linux x86_64; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre
Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre

My first guess is that you have full-page zoom disabled.  Can you check about:config for
 browser.zoom.full

That pref needs to be set to 'true' (the default value).  If it's 'false', then Firefox only zooms font-size, and so the bug you describe would actually the intended behavior in that case
WFM as well using Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:2.0b11pre) Gecko/20110202 Firefox/4.0b11pre.
Thanks Marcia -- so this isn't just some 10.5-specific quirk then.  I strongly suspect that Teodosia's just got full-page-zoom turned off, per end of comment 1.

Resolving WORKSFORME.  (Teodosia, if you can reproduce this in a fresh profile, please reopen.)
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.