OS/2 - JPG and PNG images fail to load

RESOLVED WORKSFORME

Status

SeaMonkey
General
RESOLVED WORKSFORME
17 years ago
13 years ago

People

(Reporter: Reinout van Schouwen, Assigned: mkaply)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Under some (I'm not exactly sure which) circumstances it will happen that
Warpzilla will refuse to load any JPG or PNG image. The console output looks
like this:

**************************************************
nsNativeComponentLoader: GetFactory(D:\INTERNET\WARPZILLA\BIN\components\nsjpg.d
ll) Load FAILED with error: error 2
**************************************************

running on Warp 4 US, FP14, build ID: 2000120519
(Assignee)

Comment 1

17 years ago
Can you check to see whether or not you have another jpeg.dll on your system?
(Reporter)

Comment 2

17 years ago
The only jpeg.dll I can find is in warpzilla/bin .
Also, if it existed, it would not explain why PNG files suffer from the same
problem.

Comment 3

17 years ago
*** Bug 63178 has been marked as a duplicate of this bug. ***

Comment 4

17 years ago
Reporter is this still occuring with the latest nightlies?
(Reporter)

Comment 5

17 years ago
The latest OS/2 build is of 2000-12-19 , so I really couldn't say. Mike?
(Assignee)

Comment 6

17 years ago
Could you please check to see if you have any other JPEG.DLL or PNG.DLL on your 
system?

If you have the utility chkdll32, please run it against nsjpg.dll

Thank you
(Reporter)

Comment 7

17 years ago
Mike, please see my reply from dec. 19. Also, where can I find this chkdll32
utility?
(Assignee)

Comment 8

17 years ago
sorry, I missed the earlier reply.

Here is a link to download chkdll32:

http://world.std.com/cgi-
bin/fairest.pl/software.watson.ibm.com/pub/cset++/chkdll32.exe

run chkdll32 against nsjpg.dll like this:

chkdll32 ! nsjpg.dll

As far as png goes, there could also be a "competing" png.dll.

Thanks
(Reporter)

Comment 9

17 years ago
Mike,

I am 100% positive there are no other nsjpg.dll or png.dll files on my system. I
couldn't run the CHKDLL32 utility, because the file you point to gets corrupted
somehow (HTML headers on the first few lines).

Keyser - I'm now running 2001010423, if I run into this problem again I'll get
back ASAP.

Comment 10

17 years ago
Reinout, so its no longer a problem in the latest builds?
(Reporter)

Comment 11

17 years ago
Keyser: I haven't observed the problem anymore lately. If it resurfaces I'll let
you know! =)

I'm changing the status to WORKSFORME now. 
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → WORKSFORME
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.