Don't ship with defaults/profile/prefs.js

RESOLVED FIXED in Firefox 55

Status

defect
RESOLVED FIXED
8 years ago
4 months ago

People

(Reporter: Pike, Assigned: dbugs)

Tracking

Trunk
mozilla55

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I think a bunch of defaults/profile died with omni.jar, but apparently we still have prefs.js for en-US builds, but not for l10n.

Not sure if that's a problem, but we should probably be consistent?

Spun off of bug 631222 comment 3.

Comment 1

8 years ago
It's not a problem. I wouldn't mind removing that file altogether, since it's pretty worthless.
(Reporter)

Comment 2

8 years ago
Yep, let's drop defaults/profile/prefs.js.
Summary: Localized builds don't ship with defaults/profile/prefs.js → Don't ship with defaults/profile/prefs.js
Comment hidden (mozreview-request)
Assignee: nobody → dbugs
(Assignee)

Updated

2 years ago
Attachment #8859171 - Flags: review?(benjamin)
Duplicate of this bug: 1351682

Comment 5

2 years ago
mozreview-review
Comment on attachment 8859171 [details]
Bug 631271 - Don't ship with defaults/profile/prefs.js

https://reviewboard.mozilla.org/r/131210/#review134046

\o/ small victories
Attachment #8859171 - Flags: review?(benjamin) → review+

Comment 6

2 years ago
Pushed by mbanner@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/fbab448119b7
Don't ship with defaults/profile/prefs.js r=bsmedberg

Comment 7

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/fbab448119b7
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 55
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 55 → mozilla55
You need to log in before you can comment on or make changes to this bug.