Keyword search does not URL-encode the search term

RESOLVED DUPLICATE of bug 359809

Status

()

RESOLVED DUPLICATE of bug 359809
8 years ago
8 years ago

People

(Reporter: nospam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13 ( .NET CLR 3.5.30729)

When you do a keyword search from the address bar, the search term is not URL-encoded but appended to the URL in plain text.

Reproducible: Always

Steps to Reproduce:
1. Create a bookmark with shortcut "g" and URL: http://www.google.de/search?&q=%s
2. Type the address: g 1+2

Actual Results:  
Google searches for: 1 2
This is two words.

Expected Results:  
Google computes the result of: 1 + 2
This is a math term with a plus sign in the middle.

The plus sign is actually URL-encoded and represents a single space. When I enter the plus sign in my address bar, I usually mean it. I'm a user here, not a web developer. But what happens is that the plus is appended to the URL in plain, resulting in this: http://www.google.de/search?&q=1+2. And with that, the target site can only assume that the parameter was meant to be "1 2" by the user.

I've read about using %s instead of %S in the bookmark URL, with a reference to the Mozilla wiki, but the wiki couldn't confirm that claim. Also, it would be in the wrong direction: I already use %s, using %S would make it worse, if the difference worked at all and if it could get any worse.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 359809
You need to log in before you can comment on or make changes to this bug.