Last Comment Bug 631442 - Intermittent test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1) followed by "crash" from "ASSERTION: Wrong thread!: 'NS_IsMainThread()'"
: Intermittent test_redirect-caching_passing_wrap.js | test failed (with xpcshe...
Status: RESOLVED FIXED
: intermittent-failure
Product: Core
Classification: Components
Component: Networking: HTTP (show other bugs)
: Trunk
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on:
Blocks: 438871 621386
  Show dependency treegraph
 
Reported: 2011-02-03 20:06 PST by Phil Ringnalda (:philor)
Modified: 2012-11-25 19:31 PST (History)
6 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Phil Ringnalda (:philor) 2011-02-03 20:06:04 PST
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1296782073.1296783600.27904.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/03 17:14:33
s: talos-r3-fed-030

TEST-INFO | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | running test ...
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
>>>>>>>
### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmpLUNZST/runxpcshelltests_leaks.log
pldhash: for the table at address 0x917aeb0, the given entrySize of 48 probably favors chaining over double hashing.
nsNativeModuleLoader::LoadModule("/home/cltbld/talos-slave/test/build/firefox/components/libxpcomsample.so") - load FAILED, rv: 80004005, error:
	/home/cltbld/talos-slave/test/build/firefox/components/libxpcomsample.so: cannot open shared object file: No such file or directory
TEST-INFO | (xpcshell/head.js) | test 1 pending
### XPCOM_MEM_LEAK_LOG defined -- logging leaks to /tmp/tmpLUNZST/runxpcshelltests_leaks_tab_pid5988.log
parent: TEST-INFO | (xpcshell/head.js) | test 2 pending
parent: TEST-INFO | (xpcshell/head.js) | test 2 finished
parent: TEST-INFO | (xpcshell/head.js) | running event loop
WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
WARNING: NS_ENSURE_TRUE(mMainThread) failed: file ../../../xpcom/threads/nsThreadManager.cpp, line 284
WARNING: NS_ENSURE_SUCCESS(rv, rv) failed with result 0xC1F30001: file nsThreadUtils.cpp, line 173
nsNativeModuleLoader::LoadModule("/home/cltbld/talos-slave/test/build/firefox/components/libxpcomsample.so") - load FAILED, rv: 80004005, error:
	/home/cltbld/talos-slave/test/build/firefox/components/libxpcomsample.so: cannot open shared object file: No such file or directory
pldhash: for the table at address 0x87448e0, the given entrySize of 48 probably favors chaining over double hashing.
child: TEST-INFO | (xpcshell/head.js) | test 1 pending\nchild: TEST-INFO | (xpcshell/head.js) | test 2 pending\nchild: TEST-INFO | (xpcshell/head.js) | test 2 finished\nchild: TEST-INFO | (xpcshell/head.js) | running event loop\nWARNING: SQLite returned error code 1 , Storage will convert it to NS_ERROR_FAILURE: file ../../../storage/src/mozStoragePrivateHelpers.cpp, line 108
WARNING: SQLite returned error code 1 , Storage will convert it to NS_ERROR_FAILURE: file ../../../storage/src/mozStoragePrivateHelpers.cpp, line 108
pldhash: for the table at address 0x91fe998, the given entrySize of 48 probably favors chaining over double hashing.
WARNING: NS_ENSURE_TRUE(aOriginalURI) failed: file ../../../../netwerk/protocol/http/HttpBaseChannel.cpp, line 250
child: TEST-PASS | ../unit/head_channels.js | [null : 144] 13 == 13\nchild: TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_redirect-caching_passing.js | [firstTimeThrough : 31] response body == response body\nWARNING: NS_ENSURE_TRUE(aOriginalURI) failed: file ../../../../netwerk/protocol/http/HttpBaseChannel.cpp, line 250
child: TEST-PASS | ../unit/head_channels.js | [null : 144] 13 == 13\nchild: TEST-PASS | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit/test_redirect-caching_passing.js | [finish_test : 39] response body == response body\nchild: TEST-INFO | (xpcshell/head.js) | test 1 finished\nchild: TEST-INFO | (xpcshell/head.js) | exiting test\nchild: TEST-PASS | (xpcshell/head.js) | 4 (+ 0) check(s) passed\nparent: TEST-INFO | (xpcshell/head.js) | test 1 finished
parent: TEST-INFO | (xpcshell/head.js) | exiting test
parent: TEST-INFO | (xpcshell/head.js) | No (+ 0) checks actually run
WARNING: nsExceptionService ignoring thread destruction after shutdown: file ../../../xpcom/base/nsExceptionService.cpp, line 197
###!!! ASSERTION: Wrong thread!: 'NS_IsMainThread()', file ../../../dom/ipc/ContentParent.cpp, line 278
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01860FAC]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x018609EA]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01862D94]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AD7766]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AD8FF3]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AAC788]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AA8788]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AA9C13]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AA9C8A]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AACE14]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AACF66]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01ADCC78]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AD7BD6]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01A5F020]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libxul.so +0x01AD87D9]
UNKNOWN [/home/cltbld/talos-slave/test/build/firefox/libnspr4.so +0x00030AEC]
UNKNOWN [/lib/libpthread.so.0 +0x00005AB5]
###!!! ASSERTION: Wrong thread!: 'NS_IsMainThread()', file ../../../dom/ipc/ContentParent.cpp, line 278
NOTE: child process received `Goodbye', closing down

###!!! [Child][RPCChannel] Error: Channel closing: too late to send/recv, messages will be lost

WARNING: content process _exit()ing: file ../../../dom/ipc/ContentChild.cpp, line 471
<<<<<<<
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Operating system: Linux
                  0.0.0 Linux 2.6.31.5-127.fc12.i686.PAE #1 SMP Sat Nov 7 21:25:57 EST 2009 i686
CPU: x86
     GenuineIntel family 6 model 23 stepping 10
     2 CPUs

Crash reason:  SIGABRT
Crash address: 0x175c

Thread 7 (crashed)
 0  linux-gate.so + 0x424
    eip = 0x00bb5424   esp = 0xb0cfb828   ebp = 0xb0cfb840   ebx = 0x0000175c
    esi = 0x0927d404   edi = 0x002c1ff4   eax = 0x00000000   ecx = 0x0000176f
    edx = 0x00000006   efl = 0x00200206
    Found by: given as instruction pointer in context
 1  libc-2.11.so + 0x2c349
    eip = 0x0017d34a   esp = 0xb0cfb848   ebp = 0xb0cfb968
    Found by: previous frame's frame pointer
 2  libmozalloc.so!mozalloc_abort [mozalloc_abort.cpp : 75 + 0x4]
    eip = 0x00eed048   esp = 0xb0cfb970   ebp = 0xb0cfb988
    Found by: previous frame's frame pointer
 3  0x29d831b
    eip = 0x029d831c   esp = 0xb0cfb990   ebp = 0xb0cfb998   ebx = 0x03764c94
    Found by: call frame info
(more useless stack)
20  libnspr4.so!_pt_root [ptthread.c : 187 + 0x10]
    eip = 0x00140aec   esp = 0xb0cfc2a0   ebp = 0xb0cfc2c8
    Found by: previous frame's frame pointer
Comment 1 Treeherder Robot 2011-02-06 17:02:15 PST
cdleary%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=TraceMonkey/1297038768.1297040322.11961.gz
Rev3 Fedora 12 tracemonkey debug test xpcshell on 2011/02/06 16:32:48

s: talos-r3-fed-026
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 2 Treeherder Robot 2011-02-08 16:06:28 PST
mbrubeck%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297208163.1297209686.23546.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/08 15:36:03

s: talos-r3-fed-028
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 3 Treeherder Robot 2011-02-08 16:06:36 PST
philringnalda%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297208163.1297209686.23546.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/08 15:36:03

s: talos-r3-fed-028
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 4 Treeherder Robot 2011-02-09 15:33:01 PST
jmathies%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297291861.1297293492.18419.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/09 14:51:01

s: talos-r3-fed-031
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 5 Treeherder Robot 2011-02-10 10:14:40 PST
philipp%weitershausen.de
http://tinderbox.mozilla.org/showlog.cgi?log=Places/1297359313.1297360965.31172.gz
Rev3 Fedora 12 places debug test xpcshell on 2011/02/10 09:35:13

s: talos-r3-fed-018
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 6 Treeherder Robot 2011-02-11 06:05:00 PST
hsivonen%iki.fi
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1297430837.1297432387.24648.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/11 05:27:17

s: talos-r3-fed-032
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 7 Treeherder Robot 2011-02-18 09:14:55 PST
dholbert%mozilla.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298047426.1298048987.24865.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/18 08:43:46

s: talos-r3-fed-053
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 8 Treeherder Robot 2011-02-18 09:16:01 PST
david.bolter%gmail.com
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1298047426.1298048987.24865.gz
Rev3 Fedora 12 mozilla-central debug test xpcshell on 2011/02/18 08:43:46

s: talos-r3-fed-053
TEST-UNEXPECTED-FAIL | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | test failed (with xpcshell return code: 1), see following log:
PROCESS-CRASH | /home/cltbld/talos-slave/test/build/xpcshell/tests/netwerk/test/unit_ipc/test_redirect-caching_passing_wrap.js | application crashed (minidump found)
Thread 7 (crashed)
Comment 9 Josh Matthews [:jdm] 2011-02-20 23:35:32 PST
From these logs, this orange appeared the day after bug 621386 landed, which made ContentParent destroy itself a bit more thoroughly than it used to.  It's probably a safe bet that that cleanup started tickling this.
Comment 10 Honza Bambas (:mayhemer) 2011-03-07 12:11:05 PST
Looks like there are no more reports of this.  Did anything around bug 621386 changed?
Comment 11 Josh Matthews [:jdm] 2011-03-07 13:36:10 PST
I can't imagine that bug 621386 affected anything, since it landed more than two weeks before the last orange.
Comment 12 Honza Bambas (:mayhemer) 2011-03-07 13:43:52 PST
(In reply to comment #9)
> From these logs, this orange appeared the day after bug 621386 landed..

As the bug probably caused this orange, something around the code that bug was touching might have been changed and fixed the orange.  That was what my comment meant.
Comment 13 Honza Bambas (:mayhemer) 2011-05-02 11:18:50 PDT
Looks like this is fixed.

Note You need to log in before you can comment on or make changes to this bug.