Application hung when alert pops up while dragging an image.

VERIFIED DUPLICATE of bug 100180

Status

()

--
minor
VERIFIED DUPLICATE of bug 100180
8 years ago
7 years ago

People

(Reporter: JTG, Unassigned)

Tracking

3.6 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Opera/9.80 (Windows NT 5.1; U; ru) Presto/2.7.62 Version/11.01
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; ru; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

If webpage spawns alert window when you dragging an image from this page firefox freezes.

Reproducible: Always

Steps to Reproduce:
1. Open page with sample code (see "Additional Information")
2. Press button
3. Drag an image
Actual Results:  
Alert pops up after 1 second.

Expected Results:  
Application completly freezes after alert pops up.

<html>
  <body>
    <script>
       function bug() {setTimeout('alert("Bawwwwwww")', 1000)};
    </script>
    <img src="http://www.mozilla.org/images/template/screen/logo_footer.png"><br />
    <input type="button" onclick="bug()" value="Push me and drag an image above"/>
  </body>
</html>
(Reporter)

Comment 1

8 years ago
Oops, swap the Expected and Actual result.
Until you have enabled accessibility on your machine and accessibility is guilty Disability component is not suitable for this. Moving to Generic component.
Component: Disability Access → General
QA Contact: disability.access → general

Updated

8 years ago
Version: unspecified → 3.6 Branch
Able to reproduce on Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2.13) Gecko/20101203 Firefox/3.6.13

Able to reproduce on Build identifier: Mozilla/5.0 (Windows NT 5.1; rv:2.0b12pre) Gecko/20110206 Firefox/4.0b12pre

This only happens on Windows XP and Windows 7, works fine on Mac OS X 10.6 and Ubuntu 10.4.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
V.Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.