Closed Bug 631478 Opened 10 years ago Closed 10 years ago

Firefox 4.0b11pre Crash Report [@ nsGenericElement::GetBoundingClientRect ]

Categories

(Core :: General, defect)

x86
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 630877

People

(Reporter: cbook, Unassigned)

References

Details

(Keywords: crash)

Crash Data

new Firefox 4.0b11pre Crash Report [@ nsGenericElement::GetBoundingClientRect ] -> https://crash-stats.mozilla.com/report/list?signature=nsGenericElement::GetBoundingClientRect maybe 

no comments so far - all 10.6.6 crashes - maybe related to firebug ?

Crashing Thread
Frame 	Module 	Signature [Expand] 	Source
0 	XUL 	nsGenericElement::GetBoundingClientRect 	nsINode.h:449
1 	XUL 	NS_InvokeByIndex_P 	xpcom/reflect/xptcall/src/md/unix/xptcinvoke_x86_64_unix.cpp:208
2 	XUL 	XPCWrappedNative::CallMethod 	js/src/xpconnect/src/xpcwrappednative.cpp:3071
3 	XUL 	XPC_WN_CallMethod 	js/src/xpconnect/src/xpcwrappednativejsops.cpp:1593
4 	XUL 	js::Interpret 	js/src/jscntxtinlines.h:697
5 	XUL 	js::Invoke 	js/src/jsinterp.cpp:661
6 	XUL 	js::ExternalInvoke 	js/src/jsinterp.cpp:862
7 	XUL 	JS_CallFunctionValue 	js/src/jsapi.cpp:5053
8 	XUL 	nsXPCWrappedJSClass::CallMethod 	js/src/xpconnect/src/xpcwrappedjsclass.cpp:1701
9 	XUL 	nsXPCWrappedJS::CallMethod 	js/src/xpconnect/src/xpcwrappedjs.cpp:588
10 	XUL 	PrepareAndDispatch 	xpcom/reflect/xptcall/src/md/unix/xptcstubs_x86_64_darwin.cpp:153
11 	XUL 	XUL@0xe1a37a 	
12 	XUL 	nsEventListenerManager::HandleEventSubType 	content/events/src/nsEventListenerManager.cpp:1127
13 	XUL 	nsEventListenerManager::HandleEventInternal 	content/events/src/nsEventListenerManager.cpp:1222
14 	XUL 	nsEventTargetChainItem::HandleEventTargetChain 	content/events/src/nsEventListenerManager.h:146
15 	XUL 	nsEventDispatcher::Dispatch 	content/events/src/nsEventDispatcher.cpp:628
16 	XUL 	nsEventStateManager::DispatchMouseEvent 	content/events/src/nsEventStateManager.cpp:3660
17 	XUL 	nsEventStateManager::NotifyMouseOver 	content/events/src/nsEventStateManager.cpp:3782
18 	XUL 	nsEventStateManager::GenerateMouseEnterExit 	content/events/src/nsEventStateManager.cpp:3812
19 	XUL 	nsEventStateManager::PreHandleEvent 	content/events/src/nsEventStateManager.cpp:1172
20 	XUL 	PresShell::HandleEventInternal 	layout/base/nsPresShell.cpp:7000
21 	XUL 	PresShell::HandlePositionedEvent 	layout/base/nsPresShell.cpp:6851
22 	XUL 	PresShell::HandleEvent 	layout/base/nsPresShell.cpp:6701
23 	XUL 	nsViewManager::DispatchEvent 	view/src/nsViewManager.cpp:1105
24 	XUL 	HandleEvent 	view/src/nsView.cpp:161
25 	XUL 	nsChildView::DispatchEvent 	widget/src/cocoa/nsChildView.mm:1801
26 	XUL 	nsChildView::DispatchWindowEvent 	widget/src/cocoa/nsChildView.mm:1811
27 	XUL 	-[ChildView handleMouseMoved:] 	widget/src/cocoa/nsChildView.mm:3505
28 	AppKit 	AppKit@0x13e06e 	
29 	CoreFoundation 	CoreFoundation@0x2232a 	
30 	CoreFoundation 	CoreFoundation@0x1052b 	
31 	libSystem.B.dylib 	libSystem.B.dylib@0x66b3 	
32 	CoreFoundation 	CoreFoundation@0x65f1 	
33 	CoreFoundation 	CoreFoundation@0xfcd6 	
34 	CoreFoundation 	CoreFoundation@0x1052b 	
35 	CoreFoundation 	CoreFoundation@0xfb2e 	
36 	CoreFoundation 	CoreFoundation@0xfcd6 	
37 	CoreFoundation 	CoreFoundation@0xfb2e 	
38 	libSystem.B.dylib 	libSystem.B.dylib@0x6bf9 	
39 	Foundation 	Foundation@0x61df 	
40 	libobjc.A.dylib 	libobjc.A.dylib@0x619f 	
41 	XUL 	-[ToolbarWindow sendEvent:] 	widget/src/cocoa/nsCocoaWindow.mm:2432
42 	AppKit 	AppKit@0x7287c 	
43 	CoreFoundation 	CoreFoundation@0x24688 	
44 	AppKit 	AppKit@0x714a8 	
45 	AppKit 	AppKit@0x749ec7 	
46 	AppKit 	AppKit@0x43ac5 	
47 	CoreFoundation 	CoreFoundation@0x1052b 	
48 	CoreFoundation 	CoreFoundation@0xfc42 	
49 	CoreFoundation 	CoreFoundation@0x24814 	
50 	AppKit 	AppKit@0x77e03f 	
51 	AppKit 	AppKit@0x94d9 	
52 	XUL 	nsAppShell::Run 	widget/src/cocoa/nsAppShell.mm:746
53 	XUL 	nsAppStartup::Run 	toolkit/components/startup/src/nsAppStartup.cpp:218
54 	XUL 	XRE_main 	toolkit/xre/nsAppRunner.cpp:3775
55 	firefox-bin 	main 	browser/app/nsBrowserApp.cpp:158
56 	firefox-bin 	firefox-bin@0x1953
This is the same as bug 630877; the stacks just look differently because the different compilers inline differently.
Depends on: 630877, 614347
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 630877
No longer depends on: 630877
Crash Signature: [@ nsGenericElement::GetBoundingClientRect ]
You need to log in before you can comment on or make changes to this bug.