Mozilla sometimes crashes after pressing OK on an Alert window

VERIFIED WORKSFORME

Status

()

VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: cbotev, Assigned: rogerl)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I have Mozilla build 2000110321 on Debian 2.2r2 box. Sometimes after pressing
the OK button of a JavaScript Alert window mozilla segfaults:

Program received signal SIGSEGV, Segmentation fault.
0x4064fe34 in NSGetModule () from /usr/lib/mozilla/components/libnecko.so

This happens only when the button looks depressed.

Comment 1

18 years ago
Hi Chavdar, is there a URL we could go to to reproduce this bug? We need a 
set of steps to reproduce it, otherwise we won't be able to analyze what's
going wrong. Even better would be a reduced testcase (i.e. an HTML file 
with the smallest number lines needed to show the bug). You can attach 
such a file via the "Create a new attachment" hyperlink above. 


We need steps to reproduce the bug in order to continue; thanks -
(Reporter)

Comment 2

18 years ago
Hi! This bug doesn't occur at a specific URL and it occurs just from time to
time. Sometimes it occurs several times a day, sometimes once in several days.
It occurs both when using alert() and with system notifications (like the page
timeout). So, unfortuanately, it's not easily reproducible :( I suspect that it
occurs when I click near the button edge but i'm not certain about this yet.
Now, I have suspicions that it may be a skin-related issue. I haven't had any
problems since I switched from Modern to Classic a few of days ago.

Comment 3

18 years ago
This bug has been irreproducible for me, even when I change skins.
Chavdar, what happens if you change skins back to Modern and do this
repeatedly in the URL bar: 

                  javascript: alert('Hello')


Do you ever crash like that? 

Comment 4

18 years ago
Chavdar, I suspect this bug has been fixed (i can't remember the bug number off 
the top of my head) since the 3rd of november. Could you please download and 
install a nightly build (http://ftp.mozilla.org/pub/mozilla/nightly and pick the 
most recent folder that contains a build for your platform) and re-test the 
issue you are seeing.
Thanks! 
Fabian.

Comment 5

18 years ago
I am pretty sure this is fixed now. Marking WORKSFORME. Reopen if its still a
problem in the latest nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 6

18 years ago
Marking Verified - 
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.